Saying "Alexa I am leaving" quit setting Ring to Armed

Saying “Alexa I am leaving” has always set my Ring alarm to Armed. A few days ago this quit working. Yesterday it worked again. Today it does not work. Alexa now just says bye or something. Restarting the Ring base station does not fix the problem.


Hi @PAStock. Try rebooting your Amazon Alexa device, or double check to ensure that your routine has not been altered.

Restarting the Echo does not fix the behavior. Frequently when I say I am leaving/home my Echo/Alex Auto say see you later/welcome home but do not change rhe alarm. If I say arm/disarm my security system (Ring) the Echo/Alex Auto works correctly. Sometimes one or the other works correctly.

Hi @PAStock. This Help Center article here should be helpful with this. The specific command is “Alexa, I’m leaving”. Sometimes if you add “Alexa, I AM leaving”, it may not work. I know this is subtle, but it is just a quirk of the system.

I am having the same troubles. I think something needs to be fixed. Alexa “I’m leaving” and “I’m home” Have always worked for me until the last week or two. I turned off the “Voice code” setting and turned it back on and that seemed to fix it briefly. Now neither of those will work again. And the link provided says that “I’m” should work. I did try Alexa I AM leaving. And that did work once. Ironically it tried it again just now and it’s not working again. and I’m using an echo show so I can see that it is correctly getting I’m leaving and I am leaving with neither working. Alexa I am home nor I’m home will work.

No luck. The “I’m leaving” and “I’m home” rarely work anymore. Also asking Alexa to set my Ring alarm or security system to away or home only works rarely. I had no problems for over two years. As others are now also reporting this issue it does not seem to be my equipment or setup.

I’m having the same issue. I’ve tried rebooting as well as disabling and reenabling the integration, but no luck. Any updates on this? Thanks.

The problem is still occuring. I doesn’t work most of the time. Once in a while it works, with no resetting or any other actions on my part. It worked perfectly for a couple years. I am using the command exactly as support said above.

Mine started working sporatically about 4 weeks ago and 2 weeks ago it stopped working completely. I have tried 3 different Echos, disabling the Ring skill and reinstalling and removing Ring monitoring for Guard mode. Nothing works.