S21 Ultra 4g live view

Hi,

I have multiple ring devices installed on my property that I am unable to connect to via live view when I’m not connected to wifi. Once I’m connected to wifi it works fine but this defeats the purpose of having these devices in the first place.

I have been trying to deal with Ring’s customer service on the phone which mind you is an excruciatingly painful process now and no one seems to have any idea how to fix my issue let alone being in a cue for over 40 min.

Initially they thought that it was a network provider issue (Telstra) which I indicated that it’s very unlikely as my wife is with the same provider and she isn’t experiencing these issues. Then today they release an update (3.43.0) and sent an email indicating that the issue should be resolved which it wasn’t.

I have been experiencing this issue with my phone for over 7 months and still no sight of a resolution. I’m honestly considering abandoning my ring eco system and looking elsewhere. Definitely not the same company anymore.

Is anyone experiencing similarly issues and managed to find a way to resolve it.

Hi @ABO-ZeeD. Given that this has been a longstanding concern for you, I would recommend following up with our support team. I know you mentioned that you’ve contacted them before, but since the Live View is still not working for you, you’ll want to follow up with our support team to let them know. You can tell them that you’ve contacted support about this before and that it is still happening. They’ll be able to look into this further than we can here as the Community is a neighbor-to-neighbor forum so we can’t see any of your account details. You can give our support team a call at one of the numbers available here.