Ring2 Doorbell on BT Hub6 router

Has anyone ever connected their Ring2 doorbell to a BT home Hub router.? I have tried two Ring2 devices now and neither can joing the selected network. I have tried all the usual reset, power down/up etc. I have also been in the router and switched off the 5Ghz band and used various channels. No matter what I try the device can detect the network but when selected it cannot join it and times out. Any help really appreciated.

Does anyone from RING monitor this community and offer solutions?

I have tried the replacement Ring2 that you sent to me and again I cannot get this one to connect to my wifi router either. I have gone though all the things we tried when I was on help chat including updating the Ring app.

I accessed the router and switched off the 5Ghz band so that it was only transmitting 2.4Ghz. It is a British Telecom home hub 6 dual band router.

I have also tried it on different channels (1,6,11) within the 2.4 Ghz band with no success.

The device connects to the app and can see my wifi system ID in the list of local networks. I select my wifi network and input the password correctly. The app then says it is connecting to the network and blue lights are scrolling from top to bottom on the device. This goes on for about 20 seconds then the device lights stop flashing. The app asks me to confirm the light pattern. When I say “Nothing” it just takes me back to the start of the set up process again.

I have never had any problems connecting various devices to my home wifi network. It is working properly. Given this is the second Ring2 device I have tried with no success I don’t know what to do.

The wifi service provider BT (British Telecom) are only taking support calls from customers with urgent line connection problems due to the virus situation.

I have a device which does not seem to be compatible with my wifi, but BT are probably the biggest wifi provider in the UK.

Are there any other solutions you can think of?

Sorry to hear about this @PeteScR! You’ve taken a lot of proper steps to attempt to resolve this concern. Excellent call testing on different channel frequencies!

I recommend creating a 2.4 ghz guest network on your router with a simple SSID and password, and standard security options. In the Ring app, there is an option, during the wifi connection step, to add a hidden network. While your network may not be hidden, this will allow you to manually enter your network info. I recommend trying this method.

Another variable to consider is your mobile device. Please try removing and reinstalling your Ring app, as well as ensuring bluetooth and VPN is disabled on your mobile device. I hope this helps! :slight_smile:

Marley thanks for the response. I would not know where to start with your suggestion of “I recommend creating a 2.4 ghz guest network on your router with a simple SSID and password, and standard security options.”

I will try the other option first but I am sure I have done this also before.

Pete

Marley the switching off Bluetooth and VPN made no difference.

Pete

1 Like

Marley, apparently my home router does not have the ability to set up a home guest network. Any more suggestions?

Pete

1 Like

Thanks for the update, and for trying those steps. With all you’ve tried to no avail, I recommend reaching out to our support team. They will be able to take a closer look at this concern and advise any advanced network settings or troubleshooting steps that might assist with this.

If you have not already, feel free to also check out our help center article about ports and protocols for the Video Doorbell to connect to your network.

Yep. This is exactly the same as me. I have tried everything to get it to work and upon being sent a second doorbell, still no luck. There must be a compatibility issue that ring is aware of regarding the BT home hub? Any further suggestions would be greatly appreciated… it’s doing my nut in!!

Its probably of no consolation but having read all of the steps to get around the probelm on the (UK) BT Hub6 router, my Doorbell Pro drops out of the connection after a few minutes - restarts in start up mode and announces that its the worlds most advanced doorbell. It doesnt try to reconnect, just stays in set ip mode with the spinning white light.

It appears that the support team are on reduced hours working on central european time ( so I guess not in the UK) and the chat option is closed too.

Having spent 5 hours trying all of the things mentioned above and then some, I’m ready to send it back to Amazon as faulty.