Ring would not disarm

This morning at 0500 I got up to go to work. My Ring alarm system would not disarm. It would not display my mode status. When I tried to disarm the alarm it would not let me. The Ring stayed red (home and armed) on the base station. The Internet connection (fibre) was perfect. I tried the handheld keypad, it also displayed home and armed but would not let me change the status.

I restarted the app, restarted my phone, tried the reset button on the alarm base station… nothing would work.

I ended up having to go around and unplug each camera, take the battery out of each sensor to get out of my house without setting off the alarm and leaving my family in constant noise indefinitely… it took 40 minutes to work around this problem and I was late for work. I need to ensure this will not happen again or I will change for a different system.

Hi @DonalOC. Was there a specific error or any message that you received when you were trying to disarm the Ring Alarm and it wouldn’t disarm? Was there any specific light pattern on the Keypad, or did it say anything during the disarm attempts? I’m happy to offer some general troubleshooting tips on this concern once I have a bit more information, but I may direct you to contact our support team since the ability to disarm your system with ease is important.