Ring won’t set up/connect

Hello. My ring app won’t reconnect to our wifi. Checked out our internet, it’s all good. Decided to remove decide and try re adding it and not it won’t even add the device onto our account. Any way around this??? Hoping to get it running again.

Hi @checoYchona1128. Which model of Ring Doorbell do you have? You can find the name of your Doorbell on the original packaging or on the back of the Doorbell itself. If your Doorbell is battery powered, make sure the battery is fully charged before putting it back in the Doorbell. Then perform a reset by holding down the setup button for at least 20 seconds. After the reset is done, try setting the Doorbell back up in the Ring app with the prompts under Set Up a Device. Let me know how that works for you! :slight_smile:

1 Like

It worked!! Thank you so much for your help!!! :grinning:


@checoYchona1128 Awesome, I’m glad to hear that worked and you’re all good to go. Feel free to let me know if you have any other questions! :slight_smile: