Ring won’t go live

Ring won’t go live but history and Bell work. Every time I call Ring they have no idea what is wrong so they make up stuff like your provider isn’t working when it is. Are these junk should I get rid of they are useless. Any idea why Ring would not go live on or off Wi-Fi?

2 Likes

Hi there, @nanc1233! Reaching out to our support team was a great step to take. Considering connection concerns like wifi signal and your mobile device connection is the best first step as live view depends greatly on these things. As normal events are appearing in your history, this is a great sign that your Video Doorbell is working as intended.

Try downloading the Rapid Ring app, designed for the quickest access to live view, to test live view connection there. Please also ensure there is not a vpn enabled on your mobile device. I hope this helps! :slight_smile:

Continuing the discussion from Ring won’t go live:

Has anyone figured out the live view issue ? I have an Samsung s20+ phone with the ring app installed, I have a stick up battery camera mounted outside ,when using the app on WiFi round the house everything works, but as soon as I leave the house I cant access the live view, tried everything but to no avail. Any ideas anyone before this camera hits the bin !!

Hi there, @LesHernon! If you’ve tried the suggestion above of downloading the Rapid Ring app, this app is designed for the quickest access to live view. I also recommend disabling any vpn on your mobile device. As you mentioned using android, please check for android apps that conflict with the Ring app. I hope this helps! :slight_smile:

I still can’t go live except occasionally on rapid app. Why can’t a solution be found ? I have iPhone SE and WiFi

I already have the rapid ring app and there is no vpn on my phone, I don’t think there is a solution to this problem there are too many frustrated people like me out there with the same problem.

Still no solution, phoned ring they say it is my provider talk talk, phoned talk talk they say they don’t deal with amazon !! Really !!! Might as well bin it , no help from anyone.

I have had a problem with my doorbells but not the stickup cams for a couple of months. It can’t be the wifi as both the doorbells and the stick cams are on the same damn network. When will Ring finally admit there is a problem and when will it get fixed. I just tried setting up a battery powered stick cam this morning and same as the doorbells. So you may want to look at that for a hint. I am going to have to find a doorbell that works.

One more hint Ring, the rapid app doesn’t do any better than the regular app. All battery powered stuff will not connect. All ac powered stuff does. I installed my first doorbell in 2018 and it worked great till about May of this year. Please fix this and be honest with your customers.

1 Like

Have you checked the RSSI level? It is different than your internet speed. It will greatly affect live view response time.

1 Like

Thank you neighbors, for working together in this thread to get this resolved.

@wmilam, I appreciate you covering all of those steps to narrow this down to what seems like a difference in power. Please test all event types (live view, ring button push, and motion) on your battery-powered Video Doorbell to confirm a difference in experience with each. A great test is also to charge your battery and bring the Video Doorbell inside to test and optimized environment.

For any neighbors sharing a similar concern, while I share this feedback with our teams here, completing the above and aforementioned steps in this thread will help to find a solution that works for you. :slight_smile:

So the Rapid Ring app worked for me. I couldn’t get a live view on my iPhone SE from one day to another. On my iPad it works fine. But I still don’t understand why I can’t get a live view on my Ring app anymore. Why can I get it on Rapid Ring but not Ring? Doesn’t make sense to me.

I have exactly the same problem. Upgraded to an iPhone SE yesterday. Can still get live view on my iPad. Both on latest version of iOS and latest Ring app.

I can also get it via Rapid Ring on my phone. Obviously a bug in the Ring app software somewhere.

Update: on a lark, started up my previous iPhone 5s and the live view works fine. Still does not work on iPhone SE (2020).

Exactly the same problem at our house. Both iPhones lost live view from camera a few months ago. Both had been working fine for a year prior. Works when inside the house. Does not work when out of the house. Rapid ring app no different. No VPN.

Finally after 2 months I might have solved the live view issue !!! Got In touch with ring because live view worked on WiFi they said the problem lay with my network phones three they say they don’t deal with amazon ! They put me onto Samsung, makers of my phone. After 75 mins speaking to a very patient advisor the solution came down to changing network settings down from 5g to 3g and voila live view now works !! Only problem is in poor reception areas the phone is struggling to cope with Internet on 3g but you can just change the setting back to 5g if necessary.Hope this helps someone out there, I was very close to binning the camera out of frustration so I know what it’s like.

1 Like

Thanks for figuring this out @LesHernon.

Surely Ring reps this is a Ring App issue? I have exactly the same experience. Live view works with WiFi no problems. Cellular will happily run ring recorded video whilst on 5G/4G, I have speedtests of 178mbps and plenty of signal but will never connect to live view on cellular. But as Les has said once I down train the mobile data network to 3G, live view works again.

I have a Samsung S20 with no VPN.

Surely this is an App issue? The underlying network should have no bearing, it’s just a carrier and if the app can use 5G/4G to stream doorbell recorded video, it should work for live view.