Ring wired floodlight camera keeps disconnecting and infrared off

I have a wired floodlight camera that was working for about 10 months but now it always disconnects from my wifi. When the camera disconnects, I also notice that the infrared lights are off as well (I can see they are off at night when looking at my separate home security cameras and notice the area is not lit up). I’d then need to do a power cycle on the camera which seems to resolve the problem for about a day (camera is connected, infrared is on), then it happens again. I do not think this is a router/wifi issue as I have numerous devices/cameras/lightbulbs etc. outdoors which never looses connection. Don’t think power is an issue as I have a light on the same circuit that still works.

Any idea what the problem might be? Do I need a new floodlight?

Hi @bobo126. Power cycling the Floodlight Cam was a good first troubleshooting step to try. Since it disconnected again after that, I’d recommend a full reset and fresh setup to refresh the Floodlight Cam’s connection with both your wifi network as well as with the Ring App. To reset the Camera, you’ll need to hold down the setup button for at least 20 seconds. After that, follow the steps under Set Up a Device. If this concern continues to persist after trying these steps, I would recommend contacting our support team so they can explore this further. You can give our support team a call at one of the numbers available here. Let me know what solution works or what our support team recommends. :slight_smile: