Ring will not Snooze

We have some people working in the front yard and the Ring will not stop going off. I snoozed motion alerts - didnt work. Snoozed ring alerts as well - didnt work.

I was able to turn off the notifications on my phone, but the chime and alexa keeps going off.

Very annoying. I have uninstalled it and will have to reinstall it later but that is not going to work longterm.

I see that this is a common problem - I have liked my Ring since installing it a few days ago (and am planning on getting more) but this will be enough for me to return it if it does not stop.

Has anyone else had success fixing this?

I cannot get Ring to snooze. I have followed the directions, but it did not work. What else should I do?

I am having the same problem today. I snoozed my doorbells because I have contractors working on the house all week. And it’s driving me crazy with all the alerts. Why can’t Ring get this thing to work correctly?

Btw, Their solution to everything seems to be to delete the app and reinstall it which I have done more than once.

Hi neighbors! The Snooze option in the Ring app should certainly prevent alerts from coming to your mobile device. Removing and reinstalling the Ring app was a great call. I recommend also ensuring there is not a vpn enabled when saving this snooze option.

Check out our help center article about Motion and Global Snooze for tips on using this feature. Keep in mind, while this snooze prevents alerts to your Ring app and mobile device, Alexa enabled devices and Ring Chimes will still sound for notifications. There is a Ring Chime Snooze feature, and Alexa alert options, if you run into this scenario. I hope this helps! :slight_smile: