Ring Video Pro wifi lost connection and setup wont work

hello everyone,

I recently called customer service about this but I feel the help I received maybe wasnt as good as it could have been. (not saying im not grateful, they were on the phone with me for an hour so I appreciated that)

I recently upgraded my router, although I used the same network credentials, my Ring Video Pro lost its connection. So I went ahead and pulled the cover off, hit the setup button, and it gave me the white spinning ring and everything. Yet the doorbell will not emit a wifi signal for my phone to direct connect to it. I purchased this in Novemeber 2018 and it has worked perfectly since. I verified with Ring customer service that the transformer provides enough power, the power kit on the mechanical bell is correctly installed and the wiring behind the bell itself is installed correctly.

Has anyone experienced this or has any suggestions for me to get this solved? I was thinking if there is a way to bring this back to factory, i could attempt that. Any help is greatly appreciated, its killing me I cant see my front door at all times, this is one of the most used apps on my phone.

Thanks again for reading.

1 Like

I’m having the EXACT same problem. I’ve been at this for three hours now and still haven’t figured out why it won’t connect. I came here looking for a solution an found your post. I’ve done a hard reset by holding down the side button for 30 seconds… when the blue light stopped flashing, I tried to put it in set up mode, briefly pressed the side button, got the white circle , and… it’s not sending a wifi signal to connect to. I can’t find a solution. Anybody?

  • Video Doorbell Pro-
1 Like

I have a similar problem with my Ring Video Pro. It worked fine for a couple of months but, after a local power outage, it lost connection with my wi-fi router so all I have now is an expensive door bell that sounds hi-tech when you press the button & rings my doorbell chimes inside the house. Alexa can no longer “show me the front door”, I don’t get a heads-up on my iPhone when somebody rings the door bell when I am out of house and the Ring homesite no longer records sound & video for me. I’ve gone through the setup routines, including the 30sec reset, but to no avail. It’s frustrating the hell out of me.

4 Likes

Have read your post and others related to loss of wi-fi connection. Followed all suggestions and none apply. Two devices were working fine and suddenly no connection. Frustrated and feel I need a live person to help because the FAQs are useless in my opinion except to read that others have the same problem.

1 Like

I am experiencing the same problem. Tried to do a hard reset and it is still not connecting. Paid too much for this device for it not to function correctly and I have only had it for 2 months now. Getting extremely frustrated

2 Likes

I upgraded my router today and when I did, BANG no more Ring Doorbell Pro. So I see several of us having this same issue. Is anyone getting a response or resolution to this issue? Very frustrating, as I’ve followed all of the steps and nada.

1 Like

Hey neighbors! If you have tried the troubleshooting steps other neighbors have tried but to no avail still, and you’re unable to reconnect the device via its Device Health page, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Please feel free to come back and share how you were able to get this resolved, as your answers may help other neighbors!

Just to follow up with everyone, at the time this all happened, i Called the customer service, to their credit they stayed on the phone for roughly an hour with me. None of their solutions worked for me. They deemed that since I am out of warranty, there was nothing they can do for me. So buyer beware i suppose…

So frustrating. 1st night we had the Pro it lost connection and WILL NOT for the life of me reconnect.
Both other devices are fine!! There has got to be an answer for this Ring! Come on!

1 Like

Well here’s mine, my ring pro worked fine for 2 days and then just stopped working, can’t reconnect to WiFi
Uninstalled the unit and power pro reinstalled and tried to connect…nothing
No tech support, just refer you to here, so if no solution then I’m forced to install another brand that surely may work and give the user support if something might go wrong