Ring Video Doorbell Pro suddenly sstopped working

Our Doorbell Pro has been working fine for 2 years. Nothing has changed in that time in my internet or power setup. We are still getting voltage to the unit but now have no lights at all. Signal strength is good. We’ve tried all the resetting, etc. and the unit is dead. Is there something in the unit that can fail like this after a time?

Hi @DecoDame. Thank you for letting me know what you’ve already tried so far. If the Doorbell is still unresponsive after resetting it, it could be a power-related concern. I’d recommend trying out these troubleshooting steps for power concerns related to the Doorbell Pro. If it is still not responsive after following those tips, you’ll want to reach out to our support team so they can take a deeper look. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know what solution worked for you, or what our support team recommends! :slight_smile:

We determined it was a power problem within the Ring Doorbell Pro itself. Power was available at the correct voltage at the input but never got a light. We replaced the device with a new one and it worked fine right out of the box. Don’t know exactly what was wrong, but it was definitely a device failure.

1 Like