Ring video doorbell pro major issue causing to go offline and unable to reconnect/go into setup mode

First of all, I had the original ring video doorbell pro working fine without any issues for about 4+ years up until recently, specifically mid December 2023.

I contacted ring support and they confirmed It was not receiving any power and that it was defective. So they shortly sent me a replacement ring video doorbell pro [This is the first replacement]. I removed the defective ring device and installed the new ring they sent me and was able to set it up and connect to my network fine. A few hours later, i noticed that the ring video doorbell pro had gone offline and I tried to reconnect/put it in setup mode but I would run into the issue "Unable to join the network “Ring-xxxxxx”. I did some troubleshooting to make sure the voltage from the transformer was nominal and the voltage at the ring device was nominal as well.

I once again called Ring Support and went through the troubleshooting steps with them. About an hour later with support, they looked at device diagnostics and noticed there was a wifi driver failure and said the device was defective. Support placed ANOTHER order for the ring video doorbell pro to replace the defective one they just sent me. [This is the second replacement for those keeping count]

I receive the replacement ring video doorbell pro a few days later and this time I hired an electrician to replace it for me. The electrician did mention that his company has seen a rise in issues, specifically with the ring video doorbell pro device. He checked the wiring and transformer and said everything looked fine. As a precaution, he even replaced the transformer with the one sold and recommended by Ring. He installed the ring video doorbell pro and was able to setup the device successfully to my network. Great, but just a few hours the ring video doorbell pro goes offline again and I run into the same issue "Unable to join the network “Ring-xxxxxx”. I called the electrician the next day and he came over to take a look at it and realized it was the same issue his company has been seeing in the last month. [This is the third replacement device]

I have spent countless of hours with Ring Support, my ISP, and myself just troubleshooting what is causing this issue. It looks like I am not the only one having this issue as well. This ring community is also having users reports the same issues specifically with the ring video doorbell pro device. A quick google search brings up recent posts of users reporting the same issue for this specific device with no solution or fix. Even the amazon reviews contain customers reporting the same issue just by looking at the recent reviews. I looked over to see if the “ring video doorbell pro 2” device was having the same issues but it only seems to be affecting the ring video doorbell pro model.

I am starting to think that a recent firmware/software update for the ring video doorbell pro is probably causing this issue. Maybe it’s something else, but whatever is causing this issue should be prioritized to leadership/engineering to investigate and come up with a fix/solution.

I will once again call Ring Support and go through the troubleshooting steps with them and hopefully hear a solution/fix is available. Maybe they offer to send me the ring video doorbell pro 2 model since that device seems to be operating fine? Who knows but I am out of patience and have spent too much time/energy on this already.

I wrote this up, just in case someone is running into the same issue so they are not wasting their time. Maybe someone with this issue has a solution/fix? If this issue does not get resolved, I will elevate this concern to Amazon, forums, news media, etc.

Hi @user74723. If you’ve been working with our support team, I would continue to follow their guidance. Typically, this error is caused by settings in your phone. Depending on iPhone or Android, you need to turn off WiFi Assist or Smart Network Switch. You may also need to try a different phone to establish connection or opening your WiFi setting in your phone and manually connecting. Let me know if this helps you!

Hello, I was talking with support and we verified that I had the setting for Wi-Fi Assist turned off. The ring video doorbell pro doesn’t appear to be broadcasting whenever I try to put it into setup mode. I have troubleshooted with support on different occasions and the conclusion that they come to is the ring video doorbell pro device is defective.

It seems to be an issue with multiple customers and not just me. Was there some firmware/software updated pushed out that is causing this issue and is this issue being seen on other devices? I have talked to neighbors with the Ring video doorbell pro 2 and they have not had an issue.

Hi @user74723. Since I’m not on the team that creates firmware/software, there’s not a way for me to know exactly what these updates do. Typically, these updates are done to improve functionality.

I called Ring Support earlier this week and they just ended up sending me a replacement ring video doorbell pro. The tech mentioned that the one I had was a ring video doorbell pro v2 and he mentioned he ordered a ring video doorbell pro v3 and hopefully I should not have problems.

Is there any documentation that explains or includes information on how to determine the hardware versions of the ring video doorbell pro?

I am still skeptical, that it will work and this would be my fourth replacement I would be testing within the last 2 months.

I have tried pretty much everything I can on my side from replacing the doorbell transformer with the one recommended by ring, purchasing the ring plugin adapter, resetting my network, and contacting my ISP to collect logs.

The electrician is even baffled and he mentioned he has seen an uptick of people having the same issues with the ring video doorbell pro, so it is not only just me. He mentioned that they are not recommending that specific ring video doorbell pro device since their customers report issues.

He was helpful and installed a ring video doorbell pro 2 and it worked fine with no issues for a week. He also installed two different brands of doorbells and I had no issues with it. So it seems like its an issue specifically with the ring video doorbell pro device.

I see people reporting the same issue for this device on this forum, reddit, amazon reviews, BestBuy, Lowes, home depot, etc. Please escalate this issue to leadership and the engineering team.

Hi @user74723. Thank you for sharing your experience. I will forward this to the appropriate team for further investigation.

Just to give an update. I received the replacement ring video doorbell pro. I believe this is the 4th one that ring has sent me over the period of one month. I installed it on 1/26/24 and it has been working fine without a hiccup up until today (1/30/24) where it reports it went offline. I checked the Device Health page and everything is nominal.

Transformer Voltage: Good [Green].
Last Reported Signal Strength: RSSI-56 [Green].
Status: Offline [Red]

There is something weird going on with ring. Specifically the ring video doorbell pro model.

If i try to reconnect and reset the device to go into setup mode, the ring video doorbell pro is not broadcasting the ring video doorbell pro.

Can I get an explanation on what is going on Please? I am absolutely tired of talking with support and troubleshooting with them for hours. Even my electrician said that the company he works for stopped recommending ring doorbells due to the spike in recent issues.

I have the same issue Door bell pro keeps disconnecting from WiFi, when I reconnect it I have to do a full set up by holding the button for 20 seconds just to get it to find my WiFi. I had to do this 4 times the past week. Nothing wrong with my wifi as I can stream Netflix and play games on the same channel no issues. Called support and said the door bell I have is most likely faulty but is making me buy a new one. Been a customer for year and yet that’s the best they can do for me. Probably going to find another system to replace ring where I don’t have to pay a subscription fee. They lost a customer today, maybe you should look into something else too.

1 Like

Yup, i have tried everything and it will end having the same issue. I even tried using the adapter they recommended and still end up having the same issue. My electrician ended up installing a different brand and it has been working fine without any hiccups!