Ring Video Doorbell Pro 2 Burning out Transformers

I have a Video Doorbell Pro 2. Initially installed in March and worked fine unitl late July. Installed per instruction and to correctly powered transformer (Hampton Bay from Home Depot). Troubleshooting the system revealed that the transformer was outputting nearly zero volts, so I decided to replace it. I purchased another transformer from Home Depot. After connecting, it was at 2 volts almost instantly. Figuring that I had a defective unit, I went back and exchanged for another transformer. This time, I decided to bypacss the chime and connect the Ring Pro 2 directly to the transformer. Everything appeard to be back online and the Ring was showing a healthy status at 17 volts. This worked for about 20 minutes and then the transformer burned out again. Now reading less than 1 volts. Looking at the forums it appears that I’m not the only one with this issue, but I’m failing to see an actual resolution. Any advise?

Hi @nasapat. I suggest reaching out to our support team to look into this. They’ll be able to run some diagnostic test on the Ring Pro 2 and determine what is happening here. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.