Ring video doorbell (gen2) died?

My ring video doorbell suddenly stopped working. Its gen2 sn BHR11448HZ00329. It rings on device itself but there is no button light on it and its not connecting to network. I put it on a usb charger overnight but same, rings on device itself but no any kind of button lights. Tried to reset it several times, but pressing orange button does nothing, all lights are still out. Pressed orange button for well over 20 sec (many times) to reset but no go. Is there anything else to fix this? This is quite old so i dont know about warranty? Support is very poor nowadays, no email option and chat says you have to call. Well calling is not very good solution because english is not my native language and time zone is GMT +2. I’ve had ring doorbell since startup gen1 model which was later changed to gen2 because of problems with wlan/video quality. Love this product and i’m now between buying new or trying to fix this old one somehow.

Hi @Mikjus. Thanks for sharing details on what troubleshooting steps you’ve tried so far. Since you have gone through the basic steps I would have recommended, it would be best for you to reach out to our support team at this point. While we don’t offer email and chat can’t do in-depth troubleshooting, our support team is able to assist over the phone. You can also request a translator if you would prefer a language other than English. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.