Ring Video Doorbell - A full white light continues to flash after it is set up

I am trying to set up our Ring Doorbell and I complete the setup and it tells me it is connected to the app and then the circle continues to flash with a full white light which supposedly means it is updating software however it has been doing this for 2 days!

Occasionally it stops and goes solid blue for about 5 secs and then blue flashing for 20 secs and then back to the white flash.

Can anyone help me on what I am doing wrong??

Thanks.

Hey @SLM0194. Is the device showing as online, connected and with a good RSSI in the Device Health page? If you could, next time this is happening, could you please take a recording of this so I could see what you’re seeing?

I am having the same problem with setting up my new Ring Video Doorbell! My Device Health page is actually kind of humorous, because it is saying the Power Source is Hardwired (it’s battery connected) and the Solar Charger Status is connected (it’s not). But it just keeps blinking white. The entire circle. White most of the time, but switches to blue for about 10 seconds occasionally.

It’s also not ringing to my Chime, even though it is set up properly in the app.

Hey @Chelsea_Ring–would love your help on this. Really frustrated and not getting much support!

Hey @jillianhiscock. Even though the Doorbell is using the power from the internal battery, since it seems like you have it connected to your internal chime kit, this is the reason why it is showing as hardwired. Hardwired under power source just means that it is connected and shows it’s connected to the power source from your internal chime kit. We have been having a bug in the app with the solar panel status not showing as it should, so if you do not have a solar panel installed behind your Doorbell, please disregard that section at this time.

The white ring will show on your Doorbell to signal that it is charging, as it is charging the battery from the hardwired connection that you have. The blue light will come on when the device is “on,” whether that be from a Live View, motion event, or ding at the Doorbell. Since the hardwired connection is showing in the app and on the Doorbell itself, it’s safe to assume that the wiring from your Doorbell to the internal chime kit is proper. Therefore, we may be running into a concern with the compatibility for the Doorbell to your internal chime kit. What Doorbell do you have? You can see the list of compatible chimes for the Ring Video Doorbell here and for the Ring Video Doorbell 2 here.

The problem here appears to be that the actual Ring never completes the set up, though. I don’t think it has anything to do with the Chime (which has worked fine in the past and isn’t a concern for me). As I’m going through the set up, it starts blinking when it tells me it is updating (and can take up to five minutes) and then just never stops. And as a result…never gets to the point where it allows live view, can’t link to the Chime, etc. It just keeps blinking. It isn’t charging or even detecting motion. On my original Ring Doorbell, you could see the internal red lights when it was detecting motion. That doesn’t even appear to be working.

[Note: I was just sent this new Ring Doorbell as a replacement for an already faulty device.]

@jillianhiscock When I am referencing the Doorbell to be compatible to your Chime, I’m referencing the internal chime kit in your home that may have previous Doorbell wiring sticking out that you connect your Doorbell to, not a Chime or Chime Pro from Ring. Are you connecting the Ring Doorbell to an internal chime kit, or just set up on the wall of your home?

In addition, since you have already been in contact before with our support team, I do recommend maybe reaching back out to them, as the device is still not working as designed for you. Knowing that this is a replacement Doorbell makes me feel like it may be something with the environment it was in, so if you are trying to connect the Doorbell to an internal chime kit, please let me know. Although, if you cannot get the Doorbell set back up on the account whatsoever, our support team will need to be involved again. Let me know if you reach back out to support, and if not, how the setup for the Doorbell will be so I can understand the environment better.

We do not have it hardwired to our house. We are using a battery-operated Ring Video Doorbell. I have waited on hold with Support for over 45 minutes twice this week and don’t really have time to continue to do that.

@jillianhiscock Ok awesome, thank you for clarifying that for me! I can try to assist further here, but we may run into roadblocks as I do not have your account handy since Community is not a direct line to support. Nevertheless, could you try resetting the Doorbell? For this, you will press and hold the setup button for 30 seconds. Please ensure the device is plugged into a charger while doing this, since this is the traditional Doorbell and not the 2 with the removable battery. After the reset, give the device a few minutes to reset fully and then try to set up the device again. In the event that you may get stuck in the setup, please take a screenshot of where in the app you are stuck. Hope to hear back soon! :slight_smile:

I’m having the same problem with my ring doorbell i have tried every solution listed on the help page and nothong seems to work i think the only solution to this problem overall is to return the doorbell to the shop i bought it from for a refund

I have the exact problem. But mine was a gift from 2 years ago that’s been sitting in my storage. Trying to install it at my girlfriend’s place now and it doesn’t work. Can’t really bring it back for a refund…

I’ve had a new Ring Video Doorbell 1 in my storage since 2018 Christmas. Last week I decided to install it at my mother in law’s house, and ran into issues while trying to get it to work.

Setup found wifi with no issues, and it said it’s going to update while flashing white light. It spent the next few hours alternating between flashing white for a while and then flashing blue for a while. I went through the setup process on the app, but the doorbell wouldn’t work. It continued to flash white and then blue. Pushing the doorbell doesn’t do anything. When I try to do live view, it would say ACTIVATING, and then fails. Motion detection doesn’t work either.

Thinking it might be a WiFi issue, I tried the setup process at both my mother in law’s place and my home. I get the same issues regardless of location. I tried to start the set-up from scratch at least 5 or 6 times, and each time the live view wouldn’t work. Motion detection wouldn’t work either, except once during the week when it randomly went off and sent a notification to my phone. Other than that it never detected motion again.

Is this a defective unit? I have a video doorbell at my own home and it works without any issues.

Hey @RayCarsmo, stepping in for Chelsea here. You’ll want to ensure the battery on your Doorbell is fully charged before attempting to set it up, which can take about 8 hours. Once it’s done charging, please try a reset as Chelsea had mentioned before walking through a setup in the Ring App.

If you’re still not able to get the Doorbell connected after fully charging the battery and resetting it, please give our support team a call at one of the numbers availablehere. They’ll be able to take a closer look at the device and determine what’s going on. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support.

I had the same issue with a video doorbell (original version) with cycyling between blinking white, steady blue and blinking blue. I DM’d Ring on Twitter, and after some try this and that, I was connected to Support via email. An update was sent OTA which fixed whatever the problem was and the doorbell is now working perfectly.

Now to get the chimes working again :confounded:

Jon

Replying in case someone else has this problem. I had a Ring Doorbell Pro for about two years. Successfully completed all the installation steps and had it working fine. But over time, the soft button cracked on both sides of the button in vertical lines. The doorbell and camera still worked but the cracks were unsightly. As the button is not user replaceable, they sent me a new (refurbished) Doorbell Pro.

I removed the old doorbell, deleted it from the app and tried to set up the new one using the same wiring. Set-up was uneventful until the part where it tries to connect to the internet via my WiFi router. After a couple of minutes trying to connect, I got an error saying the set-up failed as the Doorbell was “too far from the WiFi router.” The doorbell is about 12 feet from the router and had 4 bars signal strength. After this failure, the Doorbell Pro started flashing white (around the entire ring, not just one section). According to the support web site, flashing of the full ring in white means it is trying to do a firmware update. But it kept doing this for over an hour. I tried holding the reset button on the side for 30 seconds. This led to the light turning off, then after another 30 seconds or so the spinning light returned for a split second, then immediately switched back to flashing white light. I also physically unplugged the doorbell from its power wires for over 5 minutes and reconnected it, but it still went back to the flashing white light.

So I called Ring Support, went through all of the debugging steps again and they determined the unit was probably defective so they’re sending me another one. And, as expected, when I went back to my previous unit (with the broken button) setup completed perfectly and only took around 10 minutes.

TL#DR - In my case, the flashing white light on the Ring Doorbell Pro around the full circle for over an hour after a failed WiFi set-up was indicative of unit failure and required a replacement unit be sent.

1 Like

Hi @MrBoylan. Glad to hear that the support team was able to take care of this for you!