Ring Video Doorbell 4 stopped working

Hi,

I noticed that my Ring Doorbell 4 stopped working today. In the ring app I saw that it had lost WiFi connectivity 3 days ago (it would be nice that if we can get notifications if issues occur).

I have tried resetting the device by pressing the orange button for 1 second up to 20 seconds.

It seems like the device is stuck in a boot loop. It’s a flashing blue light and after a while a white spinning light comes up for a second or two. and then it just goes back to flashing blue. This behaviour is repeating.

I have tried changing battery that is fully charged but same issue persists.

Any suggestions?

Temporarily move a WiFi Access Point to the otherside of the wall from the doorbell and see if your connection is better then.
Likely this all started because it didn’t have a strong enough WiFi signal at some point.

I don’t even manage to setup the device to WiFi as it seem to restart all the time. I can’t get to a spinning white light that lasts more than 2 seconds… :smiling_face_with_tear:

Hi @rollercoaster. It seems like you have tried the basic troubleshooting steps for your Video Doorbell concern. At this point, I recommend giving our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support