Ring Video Doorbell 3 Plug Not Working

My Ring Video Doorbell 3 Plus has suddenly stopped working after only 2 and a half years.

When I put a battery in the device the following lights flash on and off but nothing else happens:

I can’t even get the device to go into setup mode.

Any ideas?

Hi @PeteDaMeat. Make sure you have fully charged the battery, which could take around 8 hours using the provided charging cable. After inserting a fully charged battery into the Video Doorbell 3, try resetting it by holding down the setup button for 20 seconds. Once the reset is done, attempt to set the Doorbell back up in the Ring app using the steps under Set Up a Device.

That should allow you to get your Doorbell reconnected in the Ring app. If that doesn’t do the trick, please follow up with our support team at one of the numbers available here to see what other troubleshooting options are available. If you are outside of the US, please visit here to see how to contact support.

Hi @Caitlyn_Ring, thank you for getting back to me.

I’ve tried the suggested steps but still no luck. After discussing with the support team, it would appear the device is dead.