Ring Video Doorbell 3 loses connection when hardwired and locks up/freezes

I have a ring video doorbell 3. Runs fine on battery. Battery is fully charged.

I hooked up the Ring Charging accessory. Worked fine. I was just trying to avoid having to remove the battery each 1-2 months. Less than 12 hours later, app said “offline”. I took the cover off the ring, all the lights were white — when I pressed the setup button – nothing happened. Doorbell was locked up/frozen. I had the charger connected via an extension cord – disconnected the extension cord, doorbell flashed blue and immediately started working.

I had originally tried hooking up the video doorbell via the wiring for the doorbell and was getting the same lock up – usually within 24 hours. So, I decided to try the dedicated Ring charger/transformer. Same exact problem.

I am on latest firmware, my wifi signal is RSSI -50 or so and I have another Ring Camera within 10 feet that never loses connection, etc.

What is going on? Anybody else experiencing this?

Try resetting your Video Doorbell by holding the setup button for 20 seconds. After reconnecting your Ring device by following the steps in this help center article, check wiring connections and test operation.

If this concern persists, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

I will call, however, the problem persists.

It happens regularly within 24 hours of plugging in the power.

If I unplug the extension cord, the camera immediately comes to life.

Something is wrong here.

Same here. Do you solve the issue?

1 Like

I have the same issue. Did any of you find a solution?

Mine is having similar problems. When I mount the doorbell it completely locks up. It will not work at all, but when removed it works fine. I have blocked the contacts temporarily, but then the house doorbell doesn’t chime.

I think the issue is with the back plate. I am ordering a replacement. When I removed it there is a circuit board that is exposed and has some corrosion and damage from moisture. I assume this is the problem for me.

Hi @cgilson33. Feel free to update this thread if the replacement back plate resolves the issue for you! If it doesn’t, this concern may best be handled with our support team so they can review some device details on the back end. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.