Ring Video Doorbell 2 not working with TP-Link Deco M9 plus


I have problems connecting my Ring Video Doorbell 2 to the WiFi network of my TP-Link Deco M9 plus. I have read several seemingly related posts. These are marked as solved while the given solution doesn’t work for my configuration.

My configuration:

Ring Video Doorbell 2 with updated firmware

TP-Link Deco M9 plus with updated firmware

I have tried connecting with and without fast roaming activated. I have tried connecting to the WiFi as well as to a WiFi Guest network 2.4 only. The results are unpredictable in the sense that no working connection is made but that the Ring shows either the top two lights or the right two lights blinking white.

Any suggestions?

Kind regards,


Hi @Felix63. Does your wifi password contain any special characters? Sometimes the special characters in the password has had some neighbors run into a concern with the device not connecting. Additionally, you may need certain ports and protocols opened on your router for the device to connect. You can learn more about that in our Ring Help Center Article here. If you still run into this concern, please reach out to our support team here. Let me know how it goes!


I am having the same trouble, but this also includes my cameras too.

I have tried with fast roaming on and off, 23.4 ghz only beam forwarding on and off, deco and ring devices have the latest firmware. Have spent days on this. Any help would be greatly appreciated. Have also sent Deco support eh same message but still not working



Also no special characters in my password just letters numbers and uppercase

From what I can tell Ring Doorbells have issues with Mesh networks. I have a replacement on the way but I don’t think it will solve the problem. I have set my Deco M5 network to send notifications when my Ring Doorbell connects and disconnects. On average it connects and disconnects every 2-3 minutes. Sometime multiples times with in a minute. I have tried a guest network set to only 2.4Ghz with beamforming on/off and fast roaming on/off and Mesh on/off on the device only.

I have since created a new wifi network with an old TP Link router and the connection seems to be stable. My conclusion is Ring + TP Link Mesh = FAIL

1 Like

I have a TP-Link Deco M9 plus mesh and just got a couple of Ring indoor cameras. I cannot get it to connect to my wifi network even during setup. I tried everything, reset my router, reset the camera, turning off the 5GHz,… but reading through these posts, it seems like I won’t be able to get them to work.

I just purchased Deco m9 and also own Ring doorbell 2. Has anyone successfully connected M9 to Ring 2?

I just recently purchased 3 spotlight cameras and they will not connect to my Deco-M5 even though there is a strong signal. I called Ring and they walked me through all the steps of turning off 5GHz, as well as trying guest network, and disabling fast roaming. Nothing has worked. They even sent me a Chimepro and it will not connect to my wifi. I have two doorbells and two spotlight cams that work, but they were added before I purchased my Deco-M5. I did purchase the alarm and has no problem setting that up. I have spent hundreds of dollars on all of this and it is frustrating that nobody can give me the answers I need. I am ready to send all of this back and move on from