Ring Video Doorbell 2 has switched from wired to battery and stopped charging

My Ring Video Doorbell 2 had been hard-wired for around 18 months without fault. Within the last 2 weeks I started to get batter low messages and in Device Health it now shows the Power Source as ‘Battery’ where it always used to say ‘Wired’. I’ve had the power supply and connections checked and it’s still receiving ~15V from the transformer (Honeywell D753 8-24V). The installer noted this is the same reading as when he first connected the device.
I’ve 100% charged the battery a couple of times now but it won’t return to the ‘Wired’ reading.

1 Like

Hi there, @ClarkeT! Depending on your battery level, a trickle charge might not be necessary, such as if it is above 90% charge. Once the battery starts to drain from usage, charge should be noticed or indicated in the Ring app. The effectiveness of this charge can depend on variables such as usage, temperature, and signal strength. If your device is still not showing as hardwiring in the Ring app device health section, please reference the tips suggested in our Hardwiring Checklist for Battery-Powered Video Doorbells. I hope this helps! :slight_smile:

Hello ClarkeT,

i recently faced the same issue…My Ring doorbell 2 is connected to power using a AC adapter and it was working fine. i had always the power source status as hardwire. but suddenly it changed to Battery source and the white light on the front went off. I checked the power adapter with a multimeter and everything was fine. I charged the battery again at 100% and reconnected the device and still showed the power source as Battery.

i could not find any real solution from Ring support Team…just links to other post or asking us to contact or call ring support. At the end, asking us to buy a new device as it has already went out of warranty.

I was able to resolve the issue myself. I dissembled the device and found that the power terminal on the backface of the Doorbell no longer has contact with the main board of the device. I just added a drop of solder in the terminal and solved the issue. Now, my device has the power source status as hardwired. and the front light is on. :smile

it seems that this pin on the main board has an internal spring that wares out with the time as i could find several customers facing the same issue.

hope this help. good luck!

Hi neighbors! We strongly advise you to not dismantle your device in any way, as it may void your warranty. You can learn more about your device’s warranty here (Warranty | Ring). Should you have any concerns with your device’s performance and you’re not able to find a solution here on the Community, please reach out to our support team before attempting to take your device apart. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.