Ring Video Door bell stuck in setup mode

I have a Video Doorbell Pro wired doorbell. I have had it connected to my wifi before and it will be connected for about a week and then it has been disconnected from the wireless network. I have been able to get it back on the network once before. It now is stuck in a loop where it won’t get out of setup mode. I never see the Ring-**** wireless network show up on my Google Pixel 7 Pro. I don’t know if it’s connected but I do see a weird wireless network that looks like a long string of alphanumeric characters show up about the same time. Any thoughts or how can I just send it back for a warranty replacement?

Hi @CyberCwby. Try rebooting your Doorbell Pro by pressing and holding the setup button for 20–25 seconds to see if it helps. If you have tried this step and are still having the same concern, give our support team a call for further assistance. Our support team will be able to further troubleshoot with you, and if a replacement is necessary, they will be able to check if your Doorbell is under warranty.

I have tried that repeatedly. Just the other day, it finally started broadcasting the wifi but I am still unable to connect to it. I keep getting booted off the network. I don’t even have the chance to say use the wifi as is. I can try again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.