Ring updates to E2EE?

In the past 24 hours I’ve noticed that 6 out of 7 Ring cameras no longer allow me to see live view or recorded motion events via the app.

These cameras have E2EE enabled but the one camera that does not have this issue is not enrolled in E2EE. When I disenroll any camera from E2EE, live view works fine, but then fails again when re-enrolling the same camera back into E2EE. I’ve had these cameras enrolled in E2EE for over a year now with zero issues until now.

Does anyone knows if there was recent update or change to E2EE on ring’s end?

So, two days ago I started having issues with end to end encryption. The videos started recording black. Now, all recordings are not able to play and are not encrypted. Also, I am not able to view live view. I spoke with a representative and did all reboot, update, reinstall app, phone update, and this did not work. So, she escalated me to a technician. He also did some test and informed me that it was end to end encryption problems and that he would also escalate it and hopefully they will have the problem fixed. Its still doing the same thing. Please help.

I am having the same problem. I posted a separate thread yesterday on the issue but am having the same symptoms, i.e. no live view or ability to see recorded motion events when devices enrolled in E2EE.

I didn’t contact ring CS because I did all the troubleshooting they would have me do anyway with no change. Glad to see they are at least aware of the issue, but I am not confident they will resolve it quickly given their prior track record.

It is definitely an internal issue on their end and nothing on the users’ end so if others are reading this and have the same issue, no need to go through all the troubleshooting steps as they will not resolve the issue.

1 Like

Wow, thanks for the response. I was beginning to think someone was hacking my security cams but I’m relieved to know that it is a. Internal error. Please Ring fix the problem as we are paying 100$ for camera services.

Hi neighbors. We appreciate you all sharing this concern with your E2EE. Rest assured that our team is investigating and working to resolve the issue as soon as possible. Thank you for your time and patience while our team works to get this resolved. I will also be marking this as a temporary solution so others who come to this thread can easily find my response. Once we have an update regarding this, we will make sure to post it here.

Thank you, I look forward to an update and/or resolution to the issue soon.

1 Like

I think I have the same issue. I enabled E2EE for my 2 new refurbished cameras and I can’t view videos / use Live View. Looking forward to the fix.

1 Like

Has any updates been done? I am still having video issues and I’m not able to view videos or live view and we are paying 100 for services.

Same problem here. When will it be fixed?


Why is it taking so long to fix this problem? What have you all done to screw this up so badly? This feature has been working reliably (for me, at least) for over one year, and out of nowhere, it just stops? Three cameras that I have (six by the OP) that are non-operational. And no, I’m not turning off E2EE so that I can use these cameras. We’re paying $100 for a service that isn’t being provided to us. You all obviously made some kind of backend change that broke this feature. I would appreciate some transparency into why this happened, and what you are doing to fix it.

1 Like

Same issue here, some of the cameras with e2ee enabled unable to record video or live view. If I dis enrolled the e2ee, it works fine. It just started happening this past few days. Video recording stops uploading on all 2nd gen Indoor cam with e2ee enabled.

Hey Justin_Ring,

It’s been just over 2 weeks since my original post and I don’t see any change wrt E2EE. Can you please provide an update as to the status of the resolution?

Update: I unenrolled E2EE on one of my three cameras. After that, the encrypted feeds on the other two cameras started working. I thought it might have been a hardware or firmware issue with the one device, possibly interrupting the encrypted feeds on all devices. So, I enrolled one of my other cameras (one that was never enrolled in E2EE), and after that, the encrypted feeds on all devices were once again broken. So, it seems that whatever backend change was made by Ring, it is only allowing two devices to be encrypted at one time.

I’m sharing this in hopes that some other affected individuals on this thread can try the same thing and report back. I’m also going to reply to my Ring support ticket with this information.

1 Like

Hello Michael,

Thank you for the update. I’ve tried to replicate what you’ve done and I can access live view when only one of my 7 ring cameras are enrolled in E2EE. It doesn’t seem to matter which camera as I have several different models. When I enroll more than one camera, all the encrypted cameras lose live view and motion recording playback, including the one that was working fine previously.

I agree that it is likely something on ring’s backend, but in my case is only allowing one encrypted device at a time.

1 Like

Thank you for testing and confirming your results. As I see it, it appears that E2EE is not completely broken, but once multiple devices are enrolled (three in my case, but only two in yours), neither of the encrypted devices will function.

I will relay this information to the Ring engineer to whom my ticket is assigned. I’ll keep you posted.

1 Like

(three in my case, but only two in yours)

Just to clarify, it’s only one device in my case. Either way, multiple device encryption is broken.

It’s strange to me that we don’t find more users affected by this…I can only assume that very few people actually use E2EE.

Also, I don’t agree with the practice of ring’s flagging this post as solved and then not responding to subsequent requests for an update.

1 Like

When I called Ring support a couple of weeks ago, one of their engineers told me that E2EE seems to be an underutilized feature, as his team doesn’t receive many tickets about it. And this was the second tier support personnel (it took me quite a while to get past the first tier, who tried to tell me that I just shouldn’t use E2EE :roll_eyes:).

And I agree: Ring shouldn’t mark a post as resolved when it obviously isn’t. Furthermore, they’ll automatically close this thread if it goes inactive for a certain number of days. Well, that will not be happening, as I will make it my life mission to keep this thread active. :grinning:

I’m also responding to every new Ring post on X/Twitter with some minor commentary as well as a link to this community post. We’ll see what happens.

1 Like

Hello all. As this forum has documented over the last year and a half, end to end encryption has essentially been a broken, non-functional feature. I have had countless conversations with @Frustrated427 about this.

This time, for the last 2-3 months, I have been unable to use live-view for all my E2EE cameras. I get a black screen with the time/seconds ticking, but no video. This happens on all my cameras, both doorbell and security camera. I was hoping ring devs would fix the issue, but I think so few users use E2EE that they are likely unaware of the issue. I am rising this issue here to see how many other users have this problem.

Additionally, for whatever reason, the ring app is taking up 15 gigabytes of my phone storage. I believe this has something to do with the way the E2EE works, but I’m not entirely sure. Do other users of the encryption features suffer this same fate?


Wow!! More E2EE users! I never thought I’d be so glad to see y’all. Let me tell you- E2EE has been a useless feature since it’s inception. From decryption errors to live vide errors to flat out non-functionality, it’s been quite the journey! I’m glad there are still a few holdouts like us.

I just created a new topic post because I was unaware this post existed. However- let me summarize- E2EE live view does not work at all. Additionally, all of my E2EE battery cameras now don’t even record video anymore or have live view- they are useless, essentially pieces of plastic.

Lastly, my phone ring app has used about 20 gigabytes in storage! It must be something to do with E2EE. anyone else have this issue? Check your phone storage and let me know if the app is gigantic.


I do not have any issues with the ring app storage. Can you unenroll all your cameras from E2EE and then just re-enroll one of them and see if you have live view and motion recording functionality? It appears as if at least one device enrolled in E2EE works, but anymore than one camera does not.