Ring stickup cam 3rd gen won’t show “device health” info. Please health

My stickup cam battery 3rd gen stop showing device health info. Please help. It give me a blank screen when I click in the “device health”.

1 Like

Doing the same thing to me, I’ve tried to reset camera, delete it from account and reinstall and still shows a blank white screen. I’ve called customer service and they have no clue.


My two stick up cams are doing the same thing can’t get the health reports to load. The backyard one even went dark from 9:30pm to 6:17am. The night vision wasn’t working. Very concerning.

Hi neighbors. We’re sorry to hear you cannot see the Device Health menu; rest assured that our team is investigating and working to the issue as soon as possible. Can you please confirm the following information for me:

  • Phone Type (iPhone 12, Galaxy Note. etc.)
  • Ring App Version
  • Type of affected Device (Stick-Up Cam, Spotlight Cam, etc.)

If there’s anything else I can help with in the meantime, please don’t hesitate to ask.

iPhone SE
Ver 5.43.0
Two Stick-Up Cams not working, Spotlight Cam still works

Same here! Just installed a Stick Up Cam Battery 3rd Gen and the Device Health screen is blank in the app. Need this option to monitor battery life! Tried to uninstall and reinstall the RING app and still blank screen.
Using app on iPhone 12
Ver. 5.43.0

The RING app update 5.43.0 caused the described problems with the Stick Up Cam 3rd Generation - and confused many iOS users (iPhone and iPad).

Deleting the camera in the app, hard reset and reinstalling it doesn’t help at all.

The problem is now well known and the RING SERVICE should correct the faulty firmware as soon as possible.

Since update 5.43.0 I have encountered another malfunction with my two RING ChimePro 2nd generation, in which the RING app crashes immediately when I click on the ChimePro Network button.

We shouldn’t be surprised if 5.43.0 shows more problems every day … Hopefully the service never sleeps!

Same problem for me.
2 x StickUp Cams
iPhone 12 Pro Max
IOS 14.7.1
Ring App 5.43.0

Same issue.
iPhone 12, IOS 14.7.1
Ring App 5.43.0
iPad Air 3rd Generation, IOS 14.7.1
Ring App 5.43.0
Wife’s iPad still has 5.42.0 and the device health page works fine.
Wish I had a way to install the previous version.

Same issue (Swedish subs., cam located in Spain)
iPhone XR, IOS14.7.1
Ring App 5.43.0
Stick Up Cam 3:rd gen, batt. with solarpanel

Same problem with security cam

We have WiFi to the stickup camera and full solar charge of battery. Have done many reboots and camera shows no health no picture and won’t connect after 9 months of great service. Help!

Same problem with not being able to see health of all of my stickup cam 3rd generation. Also one of my new stickup cam 3rd won’t detect motion when I add it into my account, but seems to work after I remove it…not sure if the firmware had anything to do with that. Going to exchange it.
iPhone 12 Pro.

I have 13 cams. All 13 are showing a blank white screen under Device Health. I can not check my battery charge level.

I have the same issue with a new stick up camera that I installed on 8/28. Also, have an issue when viewing video in app it shows one vertical line that is white at the bottom and red at the top. It is a very thin line.

I have nothing in device health. Just a blank page. I just got new WiFi so I can’t use my cameras cause I can’t change the password. Seems pretty crazy there is no other way to change password!!!

I too called support yesterday on same stickup cam device health data issue. Took 52 mins to finally talk to someone! They could not offer any additional information, I personally felt like the support specialist had no idea on the subject! Perhaps it’s time to move to another cam company!!! Seems simply to me roll back the firmware to point that was working correctly for now!!!

Sorry my apologies for the bad gramer, meant to say roll back to a point that all was working correctly!!!

@ Sixguns0und
There is another way to change your password:
Scroll down the dashboard and click on
so that you will be guided through the installation and also have the opportunity to change your router password in the middle

I’m having the same problem

1 Like