Ring Stickup Cam (3rd gen) on controller-based wireless network

I am at my wits end. This is NOT a simple wireless issue where a reboot of the router or wrong password is the issue.

I work as a network architect and as such, my wireless network is business-class. It is a Cisco 2504 wireless controller with four lightweight access points. I have 36 wireless devices in total on this particular SSID and this IOT SSID I have created does not have special characters. I have three other wireless networks. One for data with a normal SSID and pre-shared key on a different VLAN and that one has special characters. The other Data one I have requires RADIUS authentication and I know that the stick up cam will not work with it. I also have a guest wireless network not in use that only has Internet access, nothing else.

I have a Ring Doorbell Pro 2, Ring Floodlight Cam 1st Generation, and Ring Spotlight Cam Pro (on solar with two batteries)…ALL on that IOT network. I had no issues connecting those three cameras up to that WiFi network.

My phone, a ton of Kasa power strips and outlets, a Weber Connect thermometer, a Weatherflow, Rokus, NVDIA Shields, Echo Dots, Sense energy monitor, my Rachio irrigation controller…all are on that SSID, not a single issue.

But, for some reason, I have tried two different stickup cameras, and about 20 different times trying to connect this camera to my network. From the logs on the controller, it does not even try. And I tried both my IOT and my normal data wireless networks, in the range of several of my access points, all failed.

I did successfully get it to connect to my hotspot. I figured I would get it connected and then download whatever updates were available in case it was a driver issue or some sort of software issue on the code that came with it. It updated fine.

Then, I tried getting it to connect to my real wireless networks and it will not do it. It continues to go to the red/blue flashing. It simply will not connect.

And I even tried setting up a very easy temp wireless network. Nope. Nothing on a controller access point. I am NOT planning on adding a consumer-based AP just to get this to work.

I tried calling support, yesterday, but they had me replace the hardware.

I fear that is not it after trying two. There is something it does not like about my wireless network that all other devices have no issue with. If Ring or anyone can tell me what it is, fine, I will adjust my wireless network but I think this is driver, firmware of the chipset for wireless, or the wireless radio in the camera. I looked up the OUI (5C:47:5E) and Ring owns those network cards. I can try calling them again, but I am sure I will have to jump up a few levels of support to get someone to help me out…which I will try.

Hi @kahilzinger. I would strongly recommend following up with our support team regarding this concern. The Ring Community is geared towards general troubleshooting tips and tricks for common problems. That would not be helpful in this case where those steps have already been completed. When you reach out to support, your question may need to be escalated given that it deals with advanced network settings on a business-class network, as opposed to a typical home network.

1 Like

I sorted exactly the same issue by setting up a SSID with dumbed-down settings just so this one Ring camera will connect. Executive summary is you must disable roaming (802.11r), 802.11ax, and any BSS color options. I have included a screenshot of the settings of the lobotomized settings to this post. Oh, and forget about WPA3 too!