Ring Stick-Up Stopped Working with TP-Link Mesh

I previously had a Nighthawk router, but after moving into a larger home I made a change to a mesh system using the TP-Link triband mesh (Deco X68) system. I have the Ring security system with 3 stick-up cameras, a plug powered Spotlight cam, a plug powered Ring doorbell, a plug powered Mini cam, and a bunch of sensors and other devices. After changing to the new system everything works but the three stick up battery cams! They simply do not connect. Finally after a trick of plugging into another router, and then back into my TP-Link router I got them to connect and they worked fine. But then as soon as the camera battery is replaced or the router is reset the cameras stop working again and you are back to setting everything up from scratch. It is terrible.

In addition to my workaround to get them connected, I tried reserving an IP address, I tried only using the main router and not the full mesh system, I tried turning off the mesh roaming option, and enabling and disabling several other features. I have tried resetting everything, resetting the ring base station, pulling batteries and plugging back in, new batteries, etc. Nothing works.

Any advice on features or settings I can look at to get the cameras working on my setup would be appreciated.

1 Like

Think I found a solution that worked. I am pretty sure the “Fast Roaming” feature on the Deco app is what got in the way of the Stick Up cameras. Not entirely sure why, but I thought to toggle that and Beamforming and when I took off the former it seemed to start working on all cams. Now the entire setup works fine. I will keep watching and post here with any issues but my thoughts to others is to just check through all your settings. Could have saved me a lot of time!


Very interesting find @RingUser007! Please, keep us updated if anything changes.

1 Like

Does your password contain special character? I heard that may not be compatible with deco mesh. However for me to change password to all my equipment will be a major undertaking since I have many devices. I hope ring fix root of this problem.

I also have the TP link Deco mesh system and the only way to use the Ring Stick up camera is to turn off the fast roaming and the beamforming. Very frustrating, I shouldn’t have to eliminate new features for all my mobile devices so a Ring product can work. Ring needs to provide a firmware update compatible with fast roaming and beamforming otherwise I will be replacing my Ring products. Anyone aware of any other workarounds? Thanks!

I found turning fast roaming off not to work consistently. After contacting TP-Link and trying several solutions, the only fix to work all the time was to connect an extender directly to each mesh device and create separate SSID names. This forces the cameras to connect to the closest mesh hub. This also resolved similar issues with older WIFI 2.4 devices.

1 Like

Cross posting for completeness: Stick up cams keep disconnecting