Ring Stick Up Cam stuck in boot/setup loop all of a sudden

Hi all,

I have had my stick up cam elite for a while now and I’ve been nothing but super happy but yesterday all of a sudden it just went offline. Thought it was something with my WiFi but after a lot of troubleshooting it seems like something (remote firmware update?) triggered a boot loop yesterday and it just won’t come out of it.

I have tried different power options, both PoE and USB - no difference.
I have tried to hold the orange button on the back for 20+ seconds to try and reset it - no difference
I have tried with a ethernet cable connection to see if it might “wake it up”, no difference.
I have tried to push the orange button to trigger the setup mode but it doesn’t work.

The blue light just stays blue and after a while the voice is saying "Welcome to ring. Follow the instructions in the ring app to continue” and after a little while it reboots and it goes around the same way again. I can never get it to the actual setup mode, it’s “dead”.

What more options do I have?

FW version 11.0.33 according to my dashboard.

Best regards,

Hi @berisen. For this concern, it seems like you have tried the steps that I would typically recommend. I suggest reaching out to our support team on this. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.