Ring Stick up Cam Gen 3 will not connect to Anything other than my phone's Hotspot

I have been struggling with a stick up cam Gen 3 Wifi Connection for weeks now, I have tried all of the following: :putting my eero in legacy mode trying 2.4. ghz only. Tried a different brand Mesh router, Changing my SSID and Password. The Only way this thing will connect to anything is if I turn on my phones Hotspot and connect that way. It’s super annoying. I even purchased a chime pro to see If it could connect to that… no luck. This is beyond Frustrating. I have several Other cameras that work fine. This One Camera is driving me crazy. Help!

Hi @SDH021. Are you getting a specific error message? Is your WiFi password alpha-numeric? Have you ensuring you are using the correct ports and protocols? You can find that information here. Let me know if this helps.

None of that has helped. I purchased a Ring Chime Pro to see if I could get the camera to connect to the chime pro network and that failed as well. The funny part is the chime pro connected immediately. I think this camera is just bad. Also I had this camera connected to a solar panel the battery drained and that’s when this issue started happening and now it’s happening to my other Stick up cam as we speak. This is very disappointing. I spent way to much money on Ring Equipment for it to fail.

Hi @SDH021. In this case, I would suggest reaching out to our support team. Please send us a private message on Facebook @Ring or give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.