Ring spotlight camera not recognizing battery

Hello, I am looking for some help with my ring spotlight cameras.
Two of my cameras are saying that they do not have a battery installed when I replace the batteries. When I fully charge the batteries and put them in the camera, the camera connects to the network, but will not turn on live view and under device health it says “add a battery” and does not detect that there is a battery installed. Basically, Ring App is not updating the battery status after I insert fully charged batteries into the Spotlight Cam.

-I have tried different batteries, used the batteries on other cameras (and they worked), etc, so it is not a battery issue.

-I have checked the battery connections to make sure they are not dirty or corroded.

-I have tried resetting the device and setting it up again.

-I have tried uninstalling the device and reinstalling it.

-I have tried uninstalling the Ring app and reinstalling it.

-I have tried updating the device.

-I have tried installing one battery at at time and two batteries at the same time.

-I have tried changing the network under settings after setting up the device to see if it will register the battery.

-I have tried seeing if the batteries will register under “Device Health” or “Power Settings” as suggested by some ring users, that did not work.

Each time, the camera sets up just fine and has power…but does not detect a battery installed and will not show live view or record any camera views. Any help or tips would be greatly appreciated!

Hi @Amanda5. You have tried all the basic troubleshooting I would have recommended for this type of concern. The next best step is to reach out to our support team for further assistance. Give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.