Ring Spotlight Cam (wired, 1st gen) no live view or history but everything else works


I’ve been unable to get live view, video history or enriched notifications to work on the Ring Spotlight Cam (wired, first gen) since buying it two weeks ago. It connected just fine during set up. I can control the light and alarm without issue. The motion notifications work but the only image I can see is the thumbnail on the app or web which I’ve set to update every 30s.

Everything at my home is connected to 2 TP-Link Deco M4 mesh wireless routers set up in access point mode. They are hardwired back to a switch that is plugged into the modem/router from the ISP. Before yesterday, the access points were wired directly to the modem/router (no switch).

I’ve called support and completed all troubleshooting they proposed but nothing fixed my issue. Here are the details in point form:

  • tried using the camera RIGHT next to one of my access points

    • test was 65 down/13 up
    • camera said RSSI-29
  • tested the speed from outside near the camera’s permanent location

    • speed test on my phone outside next to the camera come back at 15 down and 9 up.
    • camera says RSSI-42
  • reset my modem and access points multiple times

  • I’ve read everything I could find on this forum about previous Tp-link deco mesh wifi issues (which now all claim to be resolved)

    • support reps were not aware of these and insisted everything is fine
    • support reps told me not to adjust any settings on the router even when I asked about the article about ports and other settings
    • tried with fast roaming disabled and enabled
    • tried with beam forming disabled and enabled
    • tried with the ring device having mesh enabled and disabled
    • ring cam is connected via 2.4 GHz but I also tried disabling 5ghz just in case.
  • I’ve now reset the camera (hold for 20s) multiple times.

So here are my questions;

  1. are there still issues with the TP-Link Deco routers as posted here between 2019 and 2020?

  2. do I need to/should I adjust any settings on my modem/router?

  3. is RSSI-42 good enough for the camera to work?

  4. what are the symptoms of ‘bricking’ caused by the previous ring/tp-link issue?

I’m calling technical support again tonight but my experience so far with them has me considering returning my ring devices and going with another brand.

Thanks in advance.

1 Like


Just bought a 2nd Spotlight Cam and just like yours it won’t connect to internet. It only seems to have connected to the phone app so like you can see a thumb nail, operate light from phone and can hear the notifications when there is movement but no video and or history. It is obvious that these are faulty as as deleted my other one from the app and re connected it with ease where the new one even though the camera itself says connected the phone app doesn’t think it has finished the connection.

1 Like

Thanks @Bay1 , I’ll let you know if I am able to get mine working today.

I believe they are connected to the internet as I can get its status and the thumbnail seems to come from their server (since I get updates to the image on local wifi and remotely). I also started to think this may just be a defective cam!

Do you have mesh wifi (multiple nodes) or normal wifi at home? By any chance, did you register this device during Ring’s downtime on September 22nd? I’m trying to find any other potential cause before I call their support again this evening.

I have a second one at home but I can’t set it up until Oct since someone registered it and returned it to the store. Store can’t exchange it as they have none left in stock and Ring won’t ‘unlock’ it earlier than 60 days after registration, so no other device to test at the moment.


I’ve got exactly the same issue with my ring wired spotlight cam.

I’ve tried everything but can’t get the live stream to work.

If you find a fix, please share it on here.


1 Like

I’m having the same problem with my Spotlight Hardwired camera. Did you find a solution? I don’t particularly want to take the entire length of cord out of the brackets to return it. It seems like the connection is hit or miss. I keep getting notifications of motion and the video just shows a black screen.

1 Like

Sorry only just seen your response. I have notmal wifi. Since responding to your message I have spent hours with ring customer service. I am sure they know there has been a bad batch as getting me to try everything from new firmware to another wifi connection and even when still won’t work still wanting me to try more. Only after speaking to my wifi provider who told me there is nothing wrong with my wifi did I put my foot down and told them I have right to have this replaced withi the 30 days, then they agreed to send replacement. After week of it not turning up and me chassing them, I am told they have no stock snd not sure when they will, even though they have stock in Amazon who are their parent company but wont send me one.

1 Like

I have the exact same issue with my two 1st gen spotlight cams (wired). When I purchased these I did not have this issue but moved, stored them for about a year, and unboxed to set up again. They updated their own internal firmware. When I set them back up, I get no live view (on same network or externally), I do get a thumbnail, no video upload, and no recorded video from motion.

I have tried my TP Link Deco X20, tried all settings per other threads on TP Links (guest mode to force 2.4ghz, disable fast roaming, disable beam forming). I have also set my phone as a hot spot and connected these to my phone, isolating the TP Link issue, they behave the same.

My other 3 ring devices work just fine on my network, even with TP Link settings on most optimal for my use case (beamforming and seamless roaming)

I will call support and reference this thread to post updates here.

Update: spoke to support and was escalated to neighborhood expert team.

We went through a lot of steps over the course of 3 hours…

Different routers
Tethered to iPhone (cell hotspot)
Tethered to Android (cell hotspot)
Hard resets (hold setup button for 30 seconds, and a different type 1min hold)
Memory clear (tap top button 5 times)
Support tried to push firmware update

This resulted in same results every time, agent said “firewall is blocking it” my other devices connect just fine though.

Was notified these 2 cameras are out of warranty. Very disappointed as these were 200+ bucks each new. I’ll definitely be pivoting to another brand of cameras as a result of this. This is clearly an issue with a firmware update or hardware itself at scale, due to the other responses here, and the fact that Ring does not acknowledge this within their “community” is not giving me confidence to partake in that community any longer.