Ring spotlight Cam Plus power adapter is not working

I placed my Ring Spotlight Can Plus above my garage. I paid a contractor to have the Ring power cord go through a wall so it looks nice. After a few days the power adapter stopped working (the camera worked with other cords/adapters). After back and forth a with Ring Customer support I received the correct replacement adapter. I had to pay to run it through the wall. Unfortunately, the same thing happened. The Camera received power for a day or so, then failed. I took the camera down and it works with other cords. I checked the power feed going into the Ring adapter. It is working. The failure again is with the Ring adapter/cord. Has anyone experienced this?

I enjoy the Ring community, but I’m ready to cut my losses.

Hi @Sgato29. When this happens, does the Spotlight Cam register as a wired device in the Device Health section of the Ring app? Have you tried resettings the camera? You can do this by pressing and holding the setup button for 20 seconds, then releasing it.

Hey Sgato29, the same has happened to mine. Supplied power adapted failed after a few days. I got a notification in the app to tell me the battery was low (my device doesn’t have a battery installed?) then it failed immediately after. Testing on a different adapter works fine, just no power coming from the Ring USB-C anymore.

Support is sending me a replacement, fingers crossed this one doesn’t fail also!

Had exactly the same issue; the camera was operational for less than a month. It turned out that the problem was a faulty cable adaptor, as the camera worked fine with a different cable. Currently waiting for a replacement to be delivered. Considering the timing of these posts, I’m curious if there is or was a problem with the quality/manufacturing of the adaptors themselves. Unfortunately, only Ring has access to the relevant statistics.

Hi @Arti, I’m glad to hear that our support team is sending out a replacement for this.

If any other neighbors are experiencing a similar concern, and regular troubleshooting has not worked, please reach out to our support team to see if this might be the right solution for you.

Hi everyone. I am having the exact same issues as the OP. Also placed mine above the garage. I also drilled through and ran the cord. Interestingly once the original cord they gave me went bad I replaced with my own UsB C cord. A few days later the same issue. Basically the camera is killing the USB’s power supplies. Works for a few days each time the no more. I know the cord is the issue because it won’t charge my new iPhone either. Cords worked fine before plugging into the Cam plus and then thereafter never work again. Ring is sending me a whole new unit and cord. Fingers crossed but I think these things just go bad in the rain or bad weather. Nothing being dunked underwater. Just rainfall. Then cord no longer works whether it was supplied by ring or one I found around the house. Need answers.

@user76821 , did the new unit work? @Tom_Ring I would try again if you believed the camera/cord issue has been fixed. Please let me know. -

Hi Neighbors. If you are experiencing issues where your device was previously being power, then suddenly stopped and is now unresponsive, please follow up with our support team. You can also get in touch by sending a private message @Ring on Facebook or Twitter.

Just received 2 replacement spotlight cam pros due to the same issue. Sounds like it hasn’t been corrected and the cameras will fail again after a few days.

Hopefully enough users report the issue and ring will modify the hardware.