Ring Spotlight Cam Battery not accepting recharged batteries

The battery in my Ring Spotlight Cam died a couple of weeks ago, and when I went to replace it with a fully charged battery today, it doesn’t acknowledge that the battery is good. The app still shows the battery as being 3%, despite having been fully charged, and the battery light inside the compartment is red. I then tried to use the old battery after charging it, but same result, it just won’t acknowledge that there is a charged battery, regardless of which side I insert it in (or even if I put both batteries in at the same time).

I have already tried to reset the camera by pressing the setup button for 30 seconds, but the camera does not react at all. For some background on the camera’s condition, it is kept under cover on the porch so has not been exposed to water, and it has been above 80 degrees for months, so it’s not an issue of the camera being too cold. The camera itself is less than a year old and has never given me issues before, although this is the first time the battery has actually fully died before I was able to replace it.

Any ideas on what I can do to fix it?

Same thing here and a representative said that they would send me a new battery and I have never received one and they always say that it is a 30 to 35 minute wait to talk to someone

Did you figure out a solution? I’m having the exact same issue except I have a solar panel to charge the battery.
Using the app, the battery shows that it’s dead. Even when the sun has been on the solar panel for hours.
When I’ve removed and fully Charged the battery Inside the house using the orange cord the camera still doesn’t show a charged battery. The red light is on inside the camera battery slot and the app shows a dead battery.

Hey neighbors! If you’re finding that the Ring App is not updating the battery status after you insert fully charged batteries into the Spotlight Cam, I’d suggest trying a reset. You can reset the Camera by holding down the setup button for at least 20 seconds. After that’s done, try to set it up in the Ring App again by following the steps under Set Up a Device.

If the Spotlight Cam is still not responding after trying the above, please give our support team a call at one of the numbers availablehere. They will be able to take a closer look at your device to diagnose the concern and provide more in-depth troubleshooting steps if needed. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support. :slight_smile: