Ring Spotlight Cam - Battery fully Charged, but device will not activate


I have a Ring Spotlight cam and randomly the other day the cam went offline. I thought the battery might have just died, so I fully charged the battery. After it completed charging, I put the battery inside the compartment and the little red light on the inside was solid red, but the device was not turning on. I tried another battery, and same issue.

Anyone have any idea what to do? I am at a loss with this and not sure if my device is malfunctioning. The device is only about 7 months old as well. Please help.

Reset your wifi and make sure it’s connected.

1 Like

Same here

Hey neighbors! At this time, if your Spotlight Camera will not reconnect or complete a setup, please attempt the following:

  • Ensure both of your batteries are fully charged (if you have two), or has been charging for several hours.
  • Ensure there is no debris in the battery hatch and that the hatch is closed.
  • Press the setup button on the Cam and complete the setup in the Ring app.
  • If lights flash and setup is not completing in the app, please remove and reinstall the Ring app on your mobile device, disable VPN, and have your wifi router close to your Camera (if possible). You can also see if you can set up the device on another Ring app on another phone you can log into.
  • If lights do not indicate setup mode on the Spotlight Cam, or setup is not completing, perform a reset on the Camera by holding the setup button for 20 seconds and try the setup again.

If the above steps do not result in successful setup or operation, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I got the same issue here. The camera is not turning on after pushing the battery in. A solid red light is on the battery compartment. Press the button or press & hold for over 15 seconds doesn’t help either. This is the second time I encountered this problem. First time, I replaced both cameras in Costco and this time it happened again. The camera is almost new, not too much dust or debris anywhere. I tried the suggested solution which didn’t work. Any more suggestion?