Ring Spotlight 2nd Battery Charged but not showing in app

My second battery was detected after I did a camera reboot.

1 Like

I been having the same issue with 2 cameras tried reboot camera tried reintall app same crap only shows 1 battery at 100% other at 6%

I believe its Ring issue with their firmware my cameras have workepd fine for years until just these past few weeks. But I am sure will say its a device issue even after they just sent me a replacement camera…same issue after replacing low battery with a fully charged 1

If your Spotlight Cam is not reporting an updated battery percentage in the Ring app after inserting a fully charged battery, please check the following:

  • Ensure both of your batteries are fully charged (if you have two). It takes about 8 hours for the battery to fully charge using the provided charging cable.
  • Make sure there is no debris in the battery hatch and that the hatch is firmly closed. You should also see a solid red LED on the hatch to indicate that the battery is connected.
  • Navigate off of the Device Health page, activate a Live View on your Spotlight Cam, then navigate back to the Device Health page. The Live View should have forced the Device Health screen to update.
  • On the Device Health page, scroll to the bottom and tap “Reboot This Device”. The reboot will take a few minutes. After that, reload the Device Health screen to see if the battery percentage is reporting correctly.

If the steps listed above did not work, please follow up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

That doesnt work plus Ring sent me replacement camera 2 weeks ago and issue returned 1 week later

He y Ring!

Have been a 9-camera, 3-chime customer for over 5 years…and Ring is still not receptive to the most obvious concern for any of us who use Ring Products to secure our property.

The problem is obvious: in order to reset anything on a camera or chime, I still have to press a physical button on the device. That is really a GREAT feature when I am 1,000 miles away, and my camera(s) or chime(s) need resetting! DUH!

Please put to reset button in the app as a VIRTUAL RESET BUTTON! DUH!

Here’s the logic: 1) When I am home (and thus able to push the physical reset button), then I don’t need Ring because I just use my baseball bat to take care of a security issue; 2) When I am away, I need Ring for security, but it is at that time that I cannot reset a camera or chime…WHY? I can’t push the physical button! DUH!

Come On! Your genuises in research sure nailed that one!