Ring Spotlight 2nd Battery Charged but not showing in app

Just got a new camera with extra battery.

Charged both batteries

Put both in device

App only showing one battery

One green battery indicator, on greyed out.

Right battery level says ‘Add a Battery’ in red.

Open the battery hatch on the device, two lit red led’s indicating two batteries connected.

Is this normal, i.e. only shows the other battery when it switches

Is the device borked

Or is it just that the app is sh*te?

2 Likes

I am having the same issue, but with both batteries! Does anyone know how to fix this? Or is the device broken? I have fully charged both batteries but somehow the device / app don’t recognize this.

1 Like

Same here! 2 batteries fully charged but showing as dead when they are put into the camera:(

2 Likes

So how do we get Ring to respond instead of just each other?!

2 Likes

Hey neighbors! As we are a neighbor to neighbor support forum, you may find that getting a response from a moderator may take a little while, or you may have to contact support directly for immediate assistance.

At this time, if your Spotlight Camera will not reconnect, complete a setup, or show that you have both batteries inserted, please attempt the following:

  • Ensure both of your batteries are fully charged (if you have two), or has been charging for several hours.
  • Ensure there is no debris in the battery hatch and that the hatch is closed.
  • Press the setup button on the Cam and complete the setup in the Ring app. (If already online, you may need to remove the device and then re-set it up in the app)
  • If lights flash and setup is not completing in the app, please remove and reinstall the Ring app on your mobile device, disable VPN, and have your wifi router close to your Camera.
  • If lights do not indicate setup mode on the Spotlight Cam, or setup is not completing, perform a reset on the Camera by holding the setup button for 20 seconds.

If the above steps do not result in successful setup or operation of both batteries, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Did you ever resolve that issue? I am having the same problem.

Same issue. The above fix does not work. The battery is powering just not visible in app. Returning mine.

1 Like

Hi @Danny32937. Ring was recently experiencing an outage. Please note that the issues within the app and the website would have been affecting this feature, but as of Nov 27, 11:44 UTC, a fix has been implemented and we are monitoring the results. If you are still experiencing any further issues with your Ring devices and how they were behaving previously, I recommend giving our support team a call so they can look into this further. You can give our support team a call at one of the numbers available here. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I found a solution for this. I always have the same issue. When I charge one battery and then the other, the second installed battery is not seen by the app when you check “device health”. What I do then is that I launch a “live view”, then I stop it and then both batteries and their charge can be seen in the health menu.

7 Likes

That worked for me as well. Thank you!

1 Like

Carlos_Traiy’s answer should be the official solution. Worked for me

Carlos_Traiy’s answer did not work for me, however, I backed out of “Device Health” and went into “Power Settings”. Both batteries showed up there. When I went back to “Device Health” the issue was fixed.