Ring Setup on Google Nest Wifi

I cannot get my Ring Video Pro to connect to my wifi network.

I have done tons of research and apparently the issue is that I have a Google Nest router which does not separate the 2.4g and 5g networks. I have called my internet provider, google, and ring and every time I get to the wifi connection portion it says my password is incorrect (even though I know it is correct).

The most frustrating part is it tells me it cannot connect because the password is wrong, and doesn’t even give me the option to try anything else. So I am stuck canceling the setup and starting over every time. I have probably spent at least 6 hours trying to get this to work. I cannot be the only person who has a ring doorbell and a google router.

Hi @jafields. Other than not being able to separate the 2.4 GHz and 5 GHz networks on your router, it could be other potential settings on your router causing your Doorbell not to connect. This Help Center article here has other router settings that you can look into for our Ring devices to work and connect properly. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. Because you have previously worked with our support team, you may request to speak with our advanced support team to take a deeper look into your concerns.