Ring Safety Report

I’m getting the Neighborhood Safety Report even though I have the Neighbors feature turned off. I tried turning off anything I can find to make this stop, but it still persists. Seems to happen on random mornings as well, not just Sunday morning. Has anybody found a way to turn this off on IOS, or is this still broken?

Hi there, @Beergnome! The Neighbors Safety Report can indeed be disabled on both Android and IOS devices. While logged in on your Ring app, please try the following steps:

  • Open the Menu (3 lines top left)
  • Select “Neighbors”
  • Tap the gear icon to access your Neighbors Settings
  • Under your neighbors location, select “Customize Neighbors”
  • Scroll to the Advanced Preferences section towards the bottom of this page.
  • Tap Notification Preferences
  • Toggle the Safety Report toggle found on this page.

This should work similarly on both IOS and Android. You will notice various settings and filter options along the way, which can also fine tune your Neighbors experience. I hope this helps! :slight_smile:

Marley,
Thanks for the response! I checked the setting you described, but it’s already turned off. I’m afraid I’m still getting the reports though.

Hey @Beergnome! I’ve double checked these settings with our Neighbors team who have confirmed these should disable the Neighbors Safety Report. Try checking other locations or Neighborhoods that you might have saved, that may also have these enabled. Otherwise, this may require a closer look from our support team.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know of any solutions you find with them.