Ring Pro won’t enter setup mode

Hi there, @MarkH1! This concern is often related to power variables. Checking power first will ensure that your Doorbell Pro has enough power to not only light up, but to operate and connect as intended.

Check out this hardwiring checklist which helps greatly in considering all power related variables during setup or troubleshooting. Once you’ve confirmed that power is sufficient for operation, please take the Doorbell Pro off the wires for several moments, then reattach the wiring. Allow up to an hour for your Doorbell Pro to charge up with power, then attempt a setup.

As mentioned in the other threads you’ve posted in; if the above steps do not help to resolve your concerns, our support team will be happy to take a more in-depth look for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

How can I get a replacement for my ring Pro? I have try everything but to no avail, this device work find for about 3 month and now can’t connect to my powerful wifi which is within feet from the router which I had reset many times but still no fix for this ring pro device problem.

Same issue. Cannot go into setup mode therefore cannot connect to wifi. Worked fine for years and on September 8, it stopped. I asked customer service if there was a recent firmware update and am being ghosted.
Door rings by pushing button, measured 20V at doorbell, held reset button for 30 seconds where it then spins once then blinks 14 times then goes solid white (same as MarkH1 above), disconnected from wiring for hours then reconnected. Customer service, was there a recent firmware update that might have bricked the device? Yes, No, Maybe???

I’m getting the same spin once, blinks 14 times then solid. Mine started Sept 8. Were u able to resolve???

So after doing some googling, it appears these Ring Pro Doorbells do have a non serviceable battery in them. When the battery starts to fail, the Ring will start to malfunction showing a variety of symptoms. My unit is about 3 years old, so I guess that is the lifespan of my $200 doorbell. Customer Service did offer a 35% discount and claimed the last firmware update was March 2020.

I to have had all the same troubles as everyone else. Mine worked for roughly six months and then lost all of the main features. It is only a fancy doorbell now. They need to make a recall on this and replace it. The customer service rep told me verbatim “it is an electronic device, they do not last forever”. Which is absolutely ridiculous.

I am also having this same issue. Health check shows 19V to the doorbell. It was working fine for a week and then lost connection and won’t reconnect to WiFi. Contacted customer support and they are sending me a replacement doorbell.

Same issue after mine disconnected after 12 hours. What is the number for ring support?

Hi @user18660. You can find the support team contact information in the marked solution for this post. :slightly_smiling_face: