Ring Pro will not connect since iOS 16 update

Our ring doorbell has not been functioning since the last iOS update. We have had it for 3 years, the Ring Pro

When I repair it, it first cannot connect to ring network so I force it by adding other until it appears.

Then when I connect to our home network it cannot find a network, even with a reset of the router and purchase of a Wi-Fi extender.

So I manually enter network it says it connects and it’s complete but when I go to my dashboard it says no network connection.

My router says that there is a client connected but it’s just not working.

Hi @jenblanca. There’s a few things you can try here. First, turn off power going to your Ring Pro for 10 minutes, then reconnect power. Once it powers up, perform a reset by pressing and holding the setup button for 20 seconds, then release. You should be able to complete the setup after these steps. If you are still having issue, try connecting it to a WiFi hotspot. This will let you know if there are issues with your network. I hope this helps!

This worked temporarily, and it connected for a few hours and then lost the Wi-Fi connection again.

I checked the signal multiple times to see if it was connected and it was at an optimum setting each time. I also installed a Wi-Fi booster right next to the front door.

Hi @jenblanca. I’m happy to chime in here. Since you have tried the basic troubleshooting steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

Was having the same problem with my Ring doorbell, Nest cameras and Blink camera after installing 16.0 and 16.01. Blamed it on iOS until I remembered that I switched to a new VPN the same day (I was out of town and decided to junk the old VPN). Drove me nuts all week until I remembered it tonight. Turned off the VPN (which I really didn’t need because I’m on home wifi with strong password). Problem immediately went away. Try turn off VPN if you have one. Best part was the cameras had been working all along so the things they picked up were there waiting on me to view them.

1 Like

Hi @user26934. Thanks for sharing this useful tip!