I am about to remove my Ring Pro v2, get a sledgehammer out and smash the useless over priced junk into little pieces.

I have spent the last 3 hours trying to reconnect my Ring doorbell to my Wifi. It’s worked (more or less) perfectly for the past 2 years or so.

Today our internet provider has issues and our internet is back up and running. Obviously every single internet / wifi connected item in our house has reconnected to the wifi (because it’s really that simple) EXCEPT our Ring doorbell.

Before anyone responds:

RSSI: On the app it says -57 and in green - so all good.
Mobile Phone: Apparently some issues reconnecting doorbells to wifi are caused by having your mobile data turned on, so I’ve turned it off. I’ve also restarted my phone etc etc.
Reset Doorbell: I’ve done a 20 second reset on the doorbell.
Reset Router: I’ve reset the router.

When using the app, the light will be spinning on the doorbell (white light) and I’ll be trying to connect to the Ring wifi. Every single time…NOTHING. “Cannot connect to Ring wifi”. Even manually it simply doesn’t appear.

Oh, and the spinning white light will obviously stop as well, so if you can’t connect automatically, you have to reboot the doorbell to try to get the white spinning light again to then try manually.

Does anyone know a good reliable fix??

Remember, it was working fine this morning, so I don’t want any Ring employees asking me to “make sure the router is near enough to the doorbell” etc etc.


Hi @user44262. It sounds like the part you’re getting stuck at is when you need to connect to the Ring AP. The Ring AP is a temporary “network” that you will use as an access point only during setup, before you connect it to your home wifi network.

If you can’t connect to the Ring network, try the following steps. You may have already tried some, in which case you can skip to the next step.

Apple iOS Devices

  • Reboot your device (shut it off completely), then try setting up again.
  • Change your cellular data setting. If you don’t see your home wifi network when you’re setting up your device, one of your mobile device settings may be preventing setup. You can always switch your settings back after. Learn how to access your cellular data here.
  • Change wifi settings. This often helps when you’re trying to connect to the Ring network.
    • Tap Settings (the gear icon), then tap Wifi.
    • Under this setting, you’ll see a list of different network names. Below that list, tap Ask to Join Networks, then tap Ask.
    • Try setup again to see if the Ring temporary network appears.

Android Devices

If none of these steps are successful, then you’ll want to get in touch with our support team so they can take a deeper dive. You can reach our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Yeah, done all that and it still doesn’t work…

I like how all the issues are all directed to being something wrong with wifi / Apple settings etc, rather than Ring just sorting out their own software to work properly… go figure.

I’ll call support tomorrow.