Ring Pro not working after power supply failed

Ring Pro had been getting WiFi disconnections intermittently. Was powered by 24V 40VA plug in unit. Finally stopped working about a week ago. Looks like the power supply finally gave in. Rewired in a new transformer but unable to get doorbell to reconnect to WiFi or really do anything. Currently the top half LED is flashing blue and randomly it announces that I should continue to setup within the app, but nothing works. Side button does nothing, heck the doorbell button does nothing either. Anyone have any thoughts on what to try?


Hi @Psg. Was this connected to the Ring Plug-In Adapter or a different power supply. If the blue light is flashing, that means that the Ring Pro is charging and once the blue circle is completely full, it should be able to enter setup mode. If not, you can try a reset by pressing and holding the setup button for 20 seconds, then releasing it. Let me know if this helps!

Different power supply. Previous one was not a Ring device either and worked fine for a couple of years. Took a couple of attempts on resetting and it’s finally back online

Hi @Psg. I suggest only using official Ring products to power a Ring Doorbell. These have been tested and are known to work with our devices. Third-Party devices have not been tested with our Doorbells and their performance cannot be guaranteed. I’m glad to hear that your Doorbell is now working!

Which supply do you recommend? When I had initial troubles with power back in 2019 I was advised by Ring tech support to get a supply with a rating above 30VA (my initial one was 20VA). Supply I bought lasted for a couple of years and everything worked fine until recently. Ring power adaptors I found online seem to be even lower than what the install guide recommends.