Ring Pro not entering Setup-Customer Service

Hello Everyone-

Just a bit of background, I am a IT professional with an electrical background and have remodeled numerous homes. I design networks for Fortune 100 companies.

We purchased a new home which included a Ring Pro doorbell, the home was completed in April of 2019, this year. Initially the bell rang the internal mechanical chime and showed the standard (according to the board I used a ‘bad word’ here) “the absence of any color” ring and the blue ring when the button is pressed.

I completed the set up to connect the Ring Pro to my wireless network and registered the device to the Ring website. I was receiving notifications and activity accordingly and was doing fine. I then I noticed that I was not receiving and notifications and decided to check on the unit.

I did find that the Ring Pro was no longer connected to the wireless but still rang the internal mechanical chime. I ran through everything that I could find on the FAQs and help pages to run through the resetting and programming troubleshooting but could not get the device to generate a wireless SSID to connect to my cell phone (Android) including the factory reset of 30 seconds. The device never got to the ‘blinking (according to the board I used a ‘bad word’ here) “the absence of any color” ring’. At that point I decided to call into the Ring support line for asistance.

I was conntected to a customer service representative who had me remove the device from the wall and disconnect the switch form the power and press the button 2-3 times to drain the power. Then he had me reconnect the device to power and press the reset button. Still there was no response. At this point it sounded like we had a bad transmitter and were about to issue a return- ah not in this world!

The customer representative asked me to take a photo of the power transformer to verify that the transformer was the correct type. I said that I would need to get a ladder out to get close enough to the transformer to get a good photo. Not an issue I was told you cna email him the photos once they were taken. I thought- Really, not an issue? Please keep in mind that this is a BRAND NEW HOUSE built by a national builder who installed thounsands of these a month.

I thought, OK, I will play along and told the custer rep that I will need to get a ladder out as the transformer is high on the wall. He said OK, just send them in an email and we can move forward. So, I did just that, I took pictures of the transformer and just to make sure I took my digital multimeter (voltmeter for those who are wondering) and took pictures of the connections and the display at the same time to show the tech that I do know what I am doing.

I took measurements at both the transformer output and at the Ring doorbell at each the voltage was 21.5 volt-AC well within the specifications of the required voltage of 16-24 VAC.

I sent in the photos to the Ring representative and was answered with the following:

“I got the photos for the transformer unit can you also send me a picture of the power kit supply that put inside your chime kit also to this email?”

At this point, I am thinking what else does this person want me to do? The door chime works when the switch button is pressed but the switch will not enter the set up mode. What good is getting a picture of the mechanical chime module going to do? The doorbell worked once as could be seen from the log file on my registration site at Ring and now I have to take more time to troubleshoot a doorbell that is clearly not working. I asked then representative if there was ANYTHING ELSE that they may need. And noted that this is a new install with a major builder that installs thousands of devices.

At this point I just mentioned that I couldn’t use anymore time to troubleshoot this issue and will be opening a ticket with the home builder.

I just find that this is very poor customer service as I provided more information than what was ask for and stated the obvious issues but was pretty much told that until I provided the ‘photo’ of the module to show that it is ‘compatable’ that the Customer Service representative wasn’t going to do anything. Even though the unit had previously worked.

I understand the requirements for 'process & procedure" but in todays competitive enviroment making a end user walk through multiple steps to 'prove I am not an (according to the website, I used a bad word here) “word that means less than average intelligence” is idiotic in itself.

If this is an indication of support, I am not a fan. Hopefully, my builder will replace the unit and we are good to go. If not, I (according to the board I used a ‘bad word’ here) "word that means ‘threw away my money’ on a device which will be replacing with a Ring competitor.

1 Like

What is the VA (not VAC) rating of the transformer? You mention the transfomer, but left off the most important rating—the power rating. It will usually be listed something like 16VAC@10VA or similar.