Ring pro not commmunucating with app

My ring pro v2 has worked well for about 3 years but on Saturday it went ‘offline’. It has a dedicated wifi access point next to it which is functioning properly and shows the device is on the network.

The voltage was fine at the time of last sync. It appears to be powered up and looks like its connected (it makes the doorbell noise if you push it).

I’ve done the following:

  • Reset the router
  • Manually reconnected the doorbell with the button
  • Forced reconnect via the app and the wifi setup routine
  • Long cycled the power
  • Factory reset (long button hold) followed by re-setup on freshly installed verson of the app.
  • Disabled my 5ghz network to force it to use 2.4ghz

Whenever I reconnect both the phone and the doorbell tell me it is successful but then it doesn’t work. The “last health check” time gets updated on the app to whenever I reconnect.

Firmware is 10.0.18 “up to date”.

I can ping it’s ip, the latency is fairly high (av 89 ms) but I assume that’s normal - i’ve never checked it when it’s working.

I’m starting to run out of ideas.
It seems to be the same issue as identified in this post about 2 years ago and that turned out to be a “central network issue”. Is there a new issue?
Please help!

Note: also not working on the web dashboard so it isn’t an app issue.

Hi @hellfleet. Thank you for taking the time to list out what troubleshooting steps you’ve already run through. You’ve certainly completed the basic troubleshooting steps that I would have recommended, so this could be a more advanced network issue. What router and wifi extender are you using? I can poke around the Community and see if anyone with a similar router or wifi extender experienced this type of concern.

Hi Caitlyn,

It’s a Deco mesh system from TP-Link. The ring is given “high priority” on the QoS settings.
It’s always been really reliable up to now, the access point is pretty much adjacent to the device and I get good internet connectivity if I connnect to that access point.

1 Like

Hi @hellfleet. As a test, try connecting your Ring Pro to a WiFi hotspot. If you can successfully connect to the WiFi hotspot, this would indicate that there is some sort of issue with your network. If you cannot connect to the hotspot, my guess would be the problem is with your Ring Pro. In either case, this is something that our support team can assist you with. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

@Tom_Ring That was a useful tip thanks. Used another phone as a hotspot, camera worked (although not fast enough to be useful) but it did highlight issue with local network.

Tried various things from other threads about disabling ipv6, mesh, beam forming, upnp. Tried setting up guest network. None of that helped.

Eventually I changed switched dchp back on my isp router and used the deco system as a mesh wifi access point rather than using it as a router. When i did that both the ring and chime were able to connect.

So solved but I’m not sure exactly what the issue was with the tplink deco router - it was an m5 which was the main unit. Its possible there was a recent firmware update.


@hellfleet I’m glad you found a solution that worked! I have seen other neighbors mention concerns with a TP Deco Link router or system in the past, so perhaps some of the default settings on it may not play nice with Ring devices. If you run into any problems in the future, it may also help to verify that the ports and protocols used by Ring devices are open. :slight_smile:

1 Like