Ring Pro Doorbell/new transformer/no power

I installed a Ring Doorbell Pro and also installed a new 16 V - 30V max transformer.
The doorbell worked perfectly until mail man rang doorbell, then lost all power out of the transformer to the doorbell. On the app, device health shows 0 Volts. I got a replacement transformer with the same voltage, and again it work for about 1 hour then again the ring has 0 V.
I have the Pro Power kit wired in correctly as well. I have 120V coming in to transformer and 0 V coming out of transformer. Please help. Not sure why this keeps happening?
It worked better with the old 30+ yr old underpowered transformer, but I threw it out already so now I have no doorbell :frowning:

Hi @SicWade. If you have voltage going into the transformer, but not out of the transformer, it would appear that the issue lies within the transformer. When it comes to working with the transformer, due to the nature of high voltage, I recommend reaching out to a qualified electrician.