Ring Pro does not reconnect to wifi

Hi all, I installed my ring pro last week. Everything worked, until this afternoon. The wifi connection got lost and it won’t reconnect. I tried resetting router, disconnecting electricity, resetting device. Nothing! The device is connected to the electricity network also transformator is installed correctly (worked before). The light on the bell only blinks or remain constantly on, it doesnt go into the wifi installation mode where it swirls around. Any help? I am clueless

Hey @Paulp. Could you try resetting the Pro by pressing and holding the setup button for 30 seconds? After this time has passed, give it a couple minutes and then press the setup button again. Let me know if it goes into setup mode from here!

Hi Chelsea that doesn’t help either. It just turns itself of and there after the white light is either constantly on or pulses.

It strange it does get power en worked before, but just stopped working yesterday afternoon.
Any chance its just a faulty product?

@Paulp It is possible! To verify this and have someone take a deeper look into your device’s history to see what had happened, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know what they determine for you! :slight_smile: