Ring Pro disconnected....

After an answered ring at 10:25 this morning my Ring Pro doorbell then appeared as “offline” in the app and has remained so ever since. The last reported voltage was 4023mV and the home Wi-fi signal was Strong.

I followed the various steps to reconnect several times with no luck. Other attempts included hard resets, app reinstalls eventually deleting the device from the app and attempting to add it again.

The setup would always stall at “connecting to WiFi” with a left hand white light and the message that there’s a problem with my internet connection.

My internet connection checks out fine but on checking it I discovered that the Ring Pro was actually shown as a “connected device” - identifiable by its MAC address. The device disappears from my home network if i cycle the power on it and reappears when the power is restored. It just doesn’t appear in the app (I conducted all this with phone cellular data switches off by the way).

Any further steps I can try…?

I had the same problem. When i first got the Pro an electrician came out to install because our house never had a preexisting doorbell or indoor chime, the doorbell I have been using was bluetooth and it worked great. The day of the installation he ran a new line just on the inside of the wall where the doorbell was placed outside wnd that was also the 1st day fhe doorbell went off line so the electrician came back out and made sure all the wiring was good, and it was. He called Ring customer service while he was here and they sent some signals, or whatever, and it worked again, but as soon as someone would ring the doorbell it would cut off again. The electrician came out 3 more times and every time there wers no issues on that end and customer service just had me powercycle, which never worked so I would either have to reset at the main breaker box, or unscrew the doorbell outside and disconnect/reconnect the wires, or disconnect/ reconnect power at the transformer. We started off with a 16V transformer, which is what the instructions said that came with the Pro, but after one of the calls to customer service they said that wasn’t sufficient and we needed atleast a 24V…why would this not be int he instruction manual??? Who knows, but we upgraded the transformer but that still didnt resolve the issue. Called Ring Customer Service back for the umpteenth time and they sent me a replacement. When the replacement came I was still having the same problem. The Ring Power pack, or whatever its called was installed from the very 1st time the bell was installed but that did nothing for me. I looked on the help documents on their site and kept seeing mention of a Power Pro Cable so I called Ring back again, explained again everything that was happening, whats been done and asked for one of those cables…wouldn’t you know, they don’t have that cable anymore because the power pack thing replaced the cord…why wouldn’t they put that on the siteor just remove any mention of the Power Cord, who knows. So during that last call, the representative I spoke with finally told me that the Ring Pro is not recommended in a house without a preexisting hardwired doorbell because of this problem exactly. So, I upgraded to the 3 Plus and its worked great, except for the fact that although it’s hardwired the battery isn’t keeping charged. Im currently fighting that battle as we speak and apparently the bell isnt seeing that its hardwired and there’s supposed to be some resistor connected so the bell can it is hardwired…WTH!!! I have come to realize not only are the packaged instructions vague as hell, the online “help” documents are just as bad and getting useful information fron customer service is like asking water not to be wet. All I know is that if my call today doesn’t resolve my doorbell problems I am done. Funny thing is when the electrician came out the 1st time and put the doorbell, he also installed the video floodlights and I have never had any problems with that. It’s just the doorbell.