Ring Pro 2: often not capturing the actual RING

For over half a year already i have been having the issue that the ring doorbell presses do not always result in a ring notification in the app or a notification on the Chime Pro 2 even though:

  • motion is recorded and a notification is given
  • when motion is recorded, the audible sound of the doorbell is heard when pressed

To directly give an answer to the generic questions:

  • yes, I have tried to turn it off and on… it will work temporarily but the issue always returns
  • i have made a separate 2.4GHz network to connect all my ring equipment to, since the 5ghz compatibility is too selective
  • my RSSI is -40 and the doorbell is hardwired using the provided adapter
  • i have called the local support number in the Netherlands, but frankly it is quite terrible, they have no knowledge kn the equipment and can only lead me through a “what to do in trouble flowchart”

I demand an escalation of this issue, I expect a doorbell to, at the very least, give an audible sound in my house, and even there the Ring Pro 2 fails (regardless of what the cool name and the high price may suggest)

There are a few topics on this issue that have been given a lousy response by the support team; I am hoping these can be linked together such that support understands that it is not simply a matter of giving the generic answers and being done with it.

Please feel free to respond in this topic when you are having similar issues…

Hi @chrisvonbred. The Ring Community is a public forum and we do not have access to any account or device information, meaning we cannot look as deeply into a specific concern as our support team can. We aim to provide relevant information and troubleshooting tips in an effort to help neighbors get their concerns resolved. Sometimes you may still need to reach out to our support team if the general troubleshooting doesn’t resolve it, as the issue could be more complex and requires more advanced support.

With that said, I’m still happy to see if there’s any information I can provide here that may be helpful for you. The posts you linked are similar, although based on the information in your post, it seems like the Doorbell Pro 2 itself is not registering a press of the button in the Ring app - not just that the Chime Pro isn’t playing an alert that the Doorbell has registered. When this happens, is it always immediately following when the Doorbell has detected motion? Do you see the Doorbell press registered in the Event History of your Ring app, or is it only the motion?

Thank you for your response. When it happens, only the motion is registered and the ring itself is not registered in the app nor played through the chime, although the doorbell itself outside does play the ring sound (you can also hear it during the recorded motion).

@chrisvonbred Thanks for that information. If the Doorbell ring is not registered in the Ring app, then it would not register on the Ring Chime either, so the concern is isolated to the Doorbell in this case. The RSSI you listed indicates a stable connection, so I don’t think it would be a connection-related concern either.

For general troubleshooting, you can perform a reboot first and then a full reset if the Doorbell ring is still not being properly registered. You can complete a reboot in the Ring app under the Device Health page for the Doorbell. The option should be listed at the bottom of the page, and the reboot should only take a few moments. Monitor the Doorbell after that to see if both motion and the rings are being reliably registered within the Ring app when they occur.

If the issue arises again, you can completely reset the Doorbell and walk it through a brand new setup. I’d recommend taking a screenshot of your settings for the Doorbell, as you’ll be completing a new setup. To reset the Doorbell, hold down the setup button underneath the faceplate for at least 20 seconds. Once the reset is done, follow the steps under Set Up a Device and adjust your settings as needed.

The reboot and the reset should resolve any technical problems that would prevent the Doorbell ring from being properly registered in the Ring app. If this continues, you would need to reach out to our support team for further assistance since we do not have access to any device information here.