Ring Pro 2 microphone issues

I have had my Ring Pro 2 installed now for about a week. It was working fine and now suddenly it will not record sound from outside. If someone comes to the door, they can hear me but I cannot hear them. Recorded videos do not have sound either. Going to send this back and get a Eufy.

Exactly same thing, what should I do to fix or do I return it

Same here, it’s like the microphone is dead on the Ring Pro 2 and you can’t hear anyone at the door. Also the audio from the doorbell side is missing from when you playback the footage.

I’ve also noticed there is a delay and you hear what you’ve said repeated back to yourself too.

1 Like

Check if audio recording has been disabled. In the ring app go to devices, select the doorbell, go to device settings then privacy. There is a toggle switch in there to turn audio recording on or off.

1 Like

Exact same problem as all those listed above. I have the product for only a few days.

Did you check your privacy settings to see if audio had been disabled.

Yes
Privacy settings are correct

See a few posts like this. Looks like it could be another bug in the Pro 2 to go along with the dim LED issue.

1 Like

Problem solved!
Hard reset of the device.
Hopefully this will last.

2 Likes

Hopefully that’s it sorted. Still could be a firmware issue as it shouldn’t need a hard reset to resolve. Shouldn’t have happened in the first place.

I’m having the same issue. Nothing I’ve done has been successful. I even upgraded to the transformer that Ring sells. I’m ready to throw this out the window!!

Did you check your privacy settings?

1 Like

Hi neighbors. I would recommend performing a reset on your Ring Pro 2. You can do this by pressing and holding the setup button for 20 seconds, then releasing. Additionally, you can reboot your internet router by unplugging it for 3 minutes, then plugging it back in. It can take up to 10 minutes for your internet to restore.

If you’ve tried this to no avail, I would suggest reaching out to our support team for the next best steps. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Just suffered the mic loss of sound with callers from my three week old Pro 2…
Before seeing this thread I decided to remove its power, when it came back online the mic was working again. Guess if it happens again I’ll do the hard reset, not a good start with my new ring system :frowning:

Also don’t like the dim ring blue spinning led when someone rings plus it’s not easy to see the white led even when really dark. Real shame as other cam and alarm gen 2 kit with siren is great…