Ring Pro 2 - Inside Chime Not Working

I just installed a ring pro 2 which I have hardwired. Everything on the ring itself works (chime on the ring, video, alerts, etc), but the chime inside does not work. I have a NuTone BK110NBWH-1 - it shows NuTone BK110NBWH as a compatible mechanical chime, which I’m assuming is the same as is listed. Just to verify nothing happened to the internal chime, I reconnected my original doorbell and it worked fine; I reconnected the ring pro 2 and it still doesn’t chime. Any thoughts?

I have the same problem and behavior with a pro 2 on a Nutone LA15 chime. I spent a couple of hours with tech support and we came up with the fact that my transformer (16v-10va) is underpowered to operate both the pro 2 and the chime. A voltmeter on the chime showed that the voltage dropped to 10 volts when the doorbell and chime where both activated. The tech recommended the 16v-30-va transformer that ring sells (i ordered it but have not recieved it). Looking further on the Ring support site shows that my Nutone La15 is compatible and that the transformer requirements are 16v and 10 to 40va. However, if you search for pro 2 transforner requirements, a page comes up that says the pro is 16v and 10 to 40va but the pro 2 is 30 to 40 va. Ring does not seem to have their act together and the compatibility list and transformer requirements should be front and center on the specifications page.

Thanks! That makes sense; I just checked with a neighbor and he said he had to upgrade his transformer as well, but not his chime (we had the same builder, so same transfer and chime). Appreciate the info on the voltage; I didn’t see that and the app even says the power supplied is good. I’ll get a transformer and give that a shot.

Just to follow up - I received my transformer that is a 30VA and that fixed the issue. Thanks again!

1 Like

@ctjoumas I’m glad that upgrading your transformer resolved this issue for you! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.