Ring lost connection, won’t enter setup mode

My Ring Doorbell Pro lost WiFi connection and won’t enter setup mode to reconnect it. The white light around the button pulses but won’t spin. It is getting enough power and still control my doorbell but won’t connect to the WiFi.

I have the same issue. Done a hardest and nothing works

Having the exact same issue. It’s only a month old and after successful install, it worked first day, but then it lost wifi connection and I could not get it back on. Put it away for several days and connected it againt today, then it found Wifi, and was working for an hour or so, then lost connection and cannot enter setup mode, even after a hard reset (30s). Nothing happens when pushing the setup button once. I use the transformer shipping with the product as I do not have an existing door bell or transformer in my house. The output voltage of the transformer is 30V AC between 1-4, and 18V AC between 1-3. I tried both. Last health status was 4025mvV and working.

See this video for me connecting it to power, trying entering setup mode and measuring voltage: https://youtu.be/ASEB-xdf-sk

I have the same issue. Did you find a solution? I also tried a hard reset and nothing happened.

Same with 1 of my 3 units, help!

Hi neighbors! If your Doorbell is not entering setup mode, try to reset it by holding down the setup button for at least 20 seconds. Once you allow the reset to complete, you can try to walk through the setup process again to see if the Doorbell will go into setup mode correctly. If this doesn’t resolve the problem, please give our support team a call at one of the numbers available here. They can look into this more closely and offer more in-depth troubleshooting support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: