Ring Keypad

My ring keypad doesn’t chirp or make a sound when buttons are pressed.

Hey @EChua. I recommend checking your audio settings for the Keypad and that you have the chirps turned on under Modes and the Keypad. If you go into the Ring App > Main Menu > Devices > Alarm Base Station > Keypad > ensure that your Audio Settings have the volume turned up (can try 100% and turn down from there) and that the toggle for “Play Chirps” is toggled to the right and on. Lastly, go back into the Main Menu > Settings > Modes > Disarmed > Chirps > and that chirps are turned on for when you are in Disarmed mode as well. Hope this helps! :slight_smile: