Ring keyboard

My Ring keypad (gen 1) stopped working suddenly. It continues to display a blue rotating light despite having worked before and nothing I do (and I have followed all instructions available) works to remove it or otherwise reset. I tried calling the support line but no one picked up. Is anyone able to help?

They are putting out firmware updates for gen 1 keypads so maybe it’s related to that (I just got the update yesterday afternoon). Go into the app and click on alarm, then your keypad, then event history and see what it says. Also keep the keypad plugged in and in disarmed mode to get your firmware update.

Per the event history, I think my update finished. it is having issues after.

I’m having similar, but not exactly the same issue. In the past couple of days, I’m reading more issues with the gen 1 keypad following the firmware update. I haven’t been able to resolve mine, even after a call with technical support. While my call with technical support fixed the keypad for a while, it did the firmware update again, and now it’s stopped working. I’m thinking the firmware update is impacting some people, but not all. It would be nice if Ring published their firmware updates in one spot.

Thank you for sharing your experiences with us, neighbors! Feel free to clarify what kind of concerns you are having, or any observations you are having with your Keypad. Charging and bringing the Keypad closer to the Base Station are always good steps for ruling out power and signal. Feel free to also check out our Keypad troubleshooting help center article, to see if any steps there might help.

The Software update I received on 4/18/2021 thus far had the following impact on my GEN 1 Keypads…

  1. I keep my keypads plugged in. The Green power LED that used to display in the upper left corner of the keypad is now off.

  2. The other keypad LED’s (i.e. Away, Home, Disarm) now flicker/blink periodically.

So far other than that keypad seems to be functioning properly. I know its not the keypad since suddenly both keypads I have exhibit the same “issues” after that update. I personally view this as issue, since I see no reason why a power indicator light would be turned off nor why a random blinking of the other LEDs is an enhancement to functionality. It would be nice if someone from Ring could explain the rational for these changes.

It seems to be an unintended side effect of some other power consumption issues that may have been identified, but who knows. As I said Ring should explain.

1 Like

Following the firmware update on the 18th, the power LED on my gen1 keypad shows a solid red light when it is plugged in. The lights turn off when I approach the keypad (I know there is a light some sort of sensor built-in (light or motion). The battery status indicator in the app seems normal.
I called support and they recommended performing a factory reset on the keypad , which I did, but it did not correct anything.

Thanks for clarifying further, neighbors! There was a recent firmware update that addresses this neighbor-requested features. When your Keypad is fully charged, the battery icon LED will now turn off. In addition, when using a Keypad that is plugged in, the mode LED will blink once a minute to remind you of your alarm’s current mode.

So after this update the keypad now provides no visual confirmation that it is powered; you need to look at the device on the app to see that status. You now have an extra overt step as opposed to a visual confirmation of power going to the device. A true enhancement would have allowed you to change the brightness on that particular LED (as you can on others) or turn it off completely.

The 2nd enhancement “request” seems to be even more ridiculous. The LED for the system status (Away, Home, Disarmed) are brightly colored and you can adjust the brightness in the app. Blinking an already bright LED (or however bright you prefer) does not seem to make much sense. If you can’t tell the status with a quick glance, a blink every minute is not going to make much of a difference, especially if you are not looking at the keypad at the time of the blink. An enhancement would be to change the color based on the mode. Currently Away and Home are both Red, and Disarm is blue… Why not have three distinct colors?

If this was truly intentional, I’m really not sure what you folks were thinking here.

In addition, if Ring pushes out software/firmware updates that impact the visuals and/or app functionality Ring should also push out release notes on what is changing to avoid unnecessary calls or posts on this forum. As I said I don’t this is an enhancement that improves functionality, just the opposite; however, if you pushed out notification at least owners of the impacted device would not be surprised by the functionality and think they have a faulty device.

Yes as you might have guessed, not a happy customer at the moment.

2 Likes

The firmware update is horrible. They’ve disabled the battery level light which is a huge problem for me and now the disarm button flashes constantly. I just took the keypad down and put it in a box.

1 Like

This is literally the worst update. I’ve had to take mine down. I also don’t keep my keypad plugged in due to its location in my living room. The blinking is terrible. Can these be customizable features? I don’t usually use the app the monitor the system.

1 Like

It’s a terrible update. I wish I could figure out how to bypass these “new” features. The blinking is unbelievable I had a post-it over it until I realized you can just turn all the lights off. It seems the best option, until someone accidentally sets the alarm off not knowing it is armed.

1 Like

For years now everyone has been complaining about the green LED being too bright and on all the time. The engineers finally get around to trying to satisfy the customers and, of course, people are now complaining that they miss the stupid green light. Sorry engineers, I guess sometimes you just can’t win.

I do agree that the blinking mode LED now is a little annoying, and I dispute the claim by the Ring mods here that it’s intentional and meant to “remind you what mode you’re in.” Pretty sure that the totally RANDOM and NOT occuring at exact one minute intervals blinking of mode LEDs was unintentionally caused by whatever the engineers did with the firmware update.

With regard to the post above from jrc645 about the keypad now providing no visiual confirmation that it is powered, and having to look at the app instead, a mode light constantly illuminated is your verification that’s it’s plugged in and running off of your home’s power. When it’s powered by battery the mode lights only illuminate when the motion sensor detects you approaching the keypad.

1 Like

Thanks for the clarification, I had not realized the mode lights stay on. I do believe some updates would improve functionality and hopefully at least some may eventually be implemented.

+1 to the flickering mode lights being awful and the panel lights coming on completely randomly and without any consistency anymore. This was, all around, a terribly thought out release process.

OP here. Mine had a circling blue light after the update, and now it just turned off entirely except it shows as online on my phone app so i can’t even try to reconnect etc, and nothing works. Buttons don’t work etc —- should I be just throwing this away at this point or will someone be able to help? I try calling and no one answers?

Hi there, @Sjsj385! If there seems to be no communication from the Keypad, or it will not function as intended, please bring it close to the Base Station for best signal, and plug the Keypad in to charge. Feel free to also check out our Keypad troubleshooting help center article for more steps to take.

To best reach our support team, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.